vSphere Web Client にエラー「利用可能な NSX Manager がありません (No NSX Managers available)」と表示される
search cancel

vSphere Web Client にエラー「利用可能な NSX Manager がありません (No NSX Managers available)」と表示される

book

Article ID: 342479

calendar_today

Updated On:

Products

VMware NSX Networking

Issue/Introduction

vSphere Web Client を使用して vCenter Server に接続し、[ホーム] > [ネットワークとセキュリティ] に移動すると、次の症状が発生します。
  • 使用できる NSX Managers がない。
  • ネットワークおよびセキュリティ インベントリに、NSX Manager が 0 と報告されていることが表示される。
  • [NSX ホーム] を選択すると、次のエラーが表示される。

    使用できる NSX Manager がありません。現在のユーザーが NSX Manager に割り当てられたロールを所有していることを確認してください。 (No NSX Managers available. Verify current user has role assigned on NSX Manager.)
  • NSX Manager で Lookup Service を登録解除してからもう一度登録すると、失敗する。
  • 次のエラーが表示される。

    NSX Management Service operation failed. Initialization of Admin Registration Service Provider failed. Root Cause: NSX Manager and Lookup service clocks are not in sync. They need to be synchronized. Please check NTP configuration



Symptoms:
免責事項:これは英文の記事「"No NSX Managers available" error in the vSphere Web Client (2080740)」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

Environment

VMware NSX for vSphere 6.0.x
VMware NSX for vSphere 6.3.x
VMware NSX for vSphere 6.2.x
VMware NSX for vSphere 6.1.x

Cause

この問題は、ログインしているアカウントの vCenter Server と権限が正しく構成されていない場合に発生します。

Resolution

この問題を解決するには、アカウントの権限を正しく構成します。
アカウントの権限を正しく構成するには:
  1. Web ユーザー インターフェイスを使用して、NSX Manager にログインします。
  2. [vCenter 登録の管理] をクリックします。
  3. [コンポーネント] > [NSX 管理サービス] に移動します。
  4. vCenter Server が正しく構成されていることを確認します。
また、ログインしているアカウントの権限も正しく構成されていることを確認します。ユーザー権限の詳細については、『NSX for vSphere Administration Guide』の「ユーザー管理」セクションを参照してください。

  • 同じ問題がユーザー アカウント [email protected] でも発生するかどうかを確認します。このアカウントで NSX Manager が見える場合は、問題のあるアカウントで権限が正しく構成されていることを確認します。
  • NSX Manager と Lookup Service の時刻が同期していることを確認します。詳細については、「Configuring the SSO Lookup Service fails (2102041)」を参照してください。
  • NSX のユーザー インターフェイス (UI) に vCenter Server と Lookup Service が接続済みであることが示されても、ログアウトしてから [email protected] アカウントを使用して再度ログインすると「利用可能な NSX Manager がありません (No NSX Managers available")」と表示されます。既存の VC セッションを終了する必要がある場合があります。

    これは、[ホストとクラスタ] に移動して vSphere Web Client で行うことができます。[vCenter] > [管理] > [セッション] を選択し、[すべてのセッション] ([このセッション] を除く)を選択して [セッションを終了] をクリックします。セッションからログアウトし、再度ログインします。NSX Manager が表示されるかを確認します。



Additional Information

"No NSX Managers available" error in the vSphere Web Client