Troubleshooting vpxd (vmware-vpxd-svcs) service on Windows vCenter Server
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Article ID: 342346
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Updated On:
Products
VMware vCenter Server
Issue/Introduction
This article provides steps to troubleshoot a vCenter Server service which does not start or has failed.
Symptoms:
vmware-vpxd service failed to start.
You cannot connect to VMware vCenter Server with the vSphere Client.
You cannot see the VMware vCenter Server in the inventory in the vSphere Web Client.
You may see a Microsoft Windows Event error associated with IIS similar to:
Event properties - Event 7024, Service Control Manager The VMware VirtualCenter Server service terminated with service-specific error The system cannot find the file specified. Log Name: System Source: Service Control Event ID: 7024 Level: Error
Note: A windows Event ID 1000 may also be reported in relation to this issue.
Connecting to vCenter Server fails with the error:
Cannot connect to host server_name: No connection could be made because the target machine actively refused it.
Attempting to start the VMware VirtualCenter Server service fails.
You may see this error:
Windows could not start the VMware VirtualCenter Server service on Local Computer. Error 2: The system cannot find the file specified.
If you try to start the VMware VirtualCenter Server service, you may see these errors:
Could not start the VMware VirtualCenter Server service on Local Computer. Error 1067: The process terminated unexpectedly.
Could not start the VMware VirtualCenter Server service on Local Computer. Error 1069: The service did not start due to a logon failure.
The VMware VirtualCenter Server Service on Local Computer started then stopped. Some services stop automatically if they have no work to do, for example the Performance Logs and Alerts service.
In the C:\ProgramData\VMware\VMware VirtualCenter\Logs\vpxd.log file on vCenter Server, you may see entries similar to:
[VpxdReverseProxy] Failed to create http proxy: An attempt was made to access a socket in a way forbidden by its access permissions. [Vpxd::ServerApp::Init] Init failed: VpxdMoReverseProxy::Init() Failed to intialize VMware VirtualCenter. Shutting down... Forcing shutdown of VMware VirtualCenter now.
<YYYY-MM-DD>T<time> 02128 error 'App'] [VpxdReverseProxy] Failed to create http proxy: An attempt was made to access a socket in a way forbidden by its access permissions. <YYYY-MM-DD>T<time></time> 02128 error 'App'] [Vpxd::ServerApp::Init] Init failed: VpxdMoReverseProxy::Init() <YYYY-MM-DD>T<time></time> 02128 warning 'VpxProfiler'] ServerApp::Init took 29328 ms <YYYY-MM-DD>T<time></time> 02128 error 'App'] Failed to intialize VMware VirtualCenter. Shutting down... <YYYY-MM-DD>T<time></time> 02128 info 'App'] Forcing shutdown of VMware VirtualCenter now</time>
Environment
VMware vCenter Server 5.5.x VMware vCenter Server 6.0.x VMware vCenter Server 6.7.x VMware vCenter Server 6.5.x
Cause
Potential causes of vpxd service failing on vCenter Server for Windows include, but not limited to:
Inability to connect to the vCenter Server database, especially when it is on an external server
Other database problems, such as bad or corrupt information in tables or in the ODBC configuration file
Corruption of critical .dlls or configuration files in the Windows system
Disk problems on the vCenter or external database server
Incompatible plug-ins
Missing critical vCenter Server files or folders
Incompatible hardware changes to the vCenter Server machine
Resolution
Notes:
Validate if each troubleshooting step below is true for your environment. Each step provides instructions or a link to a document that helps eliminate possible causes and take corrective action as necessary. The steps are ordered in the most appropriate sequence to isolate the issue and identify the proper resolution. Do not skip a step.
Completing the prescribed steps in this section may help to eliminate common causes of this problem by verifying the database configuration, validating network connectivity, and verifying the configuration of the VMware VirtualCenter Server service.
To troubleshoot the VMware Virtual Center Server service when it does not start or fails:
Note: If you perform a corrective action in any of these steps, attempt to restart the VMware VirtualCenter Server service.
Verify that the VMware VirtualCenter Server service cannot be restarted.
Open the Microsoft Services control panel and check the status of the service. For more information on starting the VMware VirtualCenter service if it has stopped.
If not, your database administrator might have to provide the correct password or change it
Verify that DNS or Active Directory contains the correct IP information for both the vCenter Server machine and the database server if that server is separate from the vCenter machine.
If not, your DNS/AD team may have to correct the addresses
Verify if there is enough free disk space on vCenter Server.
Verify that the required ports are available on the vCenter Server machine. For more information, see TCP and UDP Ports required to access VMware vCenter Server, VMware ESXi and ESX hosts, and other network components. If another application, such as Microsoft Internet Information Server (IIS) (also known as Web Server (IIS) on Windows 2008 Enterprise), Routing and Remote Access Service (RAS), World Wide Web Publishing Services (W3SVC), Windows Remote Management service (WS-Management) or the Citrix Licensing Support service are using any of the ports, vCenter Server cannot start.
Verify the health of the database server that is being used for vCenter Server. If the hard drives are out of space, the database transaction logs are full, or if the database is heavily fragmented, vCenter Server may not start. For troubleshooting steps when using a Microsoft SQL database, see Investigating the health of a vCenter Server database.
Verify whether the problem is due to vCenter Server database errors.
Navigate to the C:\ProgramData\VMware\vCenter Server\Logs\vmware-vpx directory
If your vCenter Server was installed to a different drive or directory, you'll need to look in that path
Open the most recent vpxd.log file in Notepad or other text editor.
Look for entries containing "error vpxd" and "SQL"
If found, there are likely to be database problems preventing vpxd from starting
Many database errors are best resolved by VMware technical staff.
Verify if the VMware VirtualCenter Server service is running with the proper credentials
Verify that critical folders exist on vCenter Server
Verify that no hardware or software changes are made to vCenter Server that causes the issue.
If you have recently made any changes to the vCenter Server, undo these changes temporarily for testing purposes.
Please be aware sometimes an update will change configuration and removing it will not reverse the change
Updates will commonly re-activate a program such as Microsoft IIS that takes over a port required by vCenter Server. Check the list of services for such applications.
Look in the Windows System and Application event logs for any information showing there is a problem with a vCenter Server .dll file
If so, vCenter Server will likely need to be restored from backup or reinstalled.
Before launching vCenter Server 5.x, ensure that the VMwareVCMSDS service is running.
Verify that the vpxd.exe file is present in C:\Program Files\VMware\Infrastructure\VirtualCenter Server\vpxd.exe location. If this file is not present, reinstall vCenter Server.
If your problem still exists after trying the steps in this article:
Reviewing the vpxd.log files is another common method of diagnosing vCenter Server when it does not start. By reviewing the log files, you can quickly determine the cause of the problem based on the error message reported.
To review the logs, open the most recent log in an editor, such as Notepad, and navigate to the bottom of the file. If there were any errors during the VirtualCenter Server startup service, it is listed in the file.
For information on troubleshooting vpxd service problems in the vCenter Server Appliance, see: vpxd service fails to start