Accessing the virtual machine console through the vSphere Client or Web Client displays a black screen
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Accessing the virtual machine console through the vSphere Client or Web Client displays a black screen

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Article ID: 342269

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • Cannot access the virtual machine console using the vSphere Client or Web Client
  • When you access the virtual machine console through the vSphere Client or Web Client, the console screen appears black
  • You do not see any MKS errors


Environment

VMware ESXi 4.1.x Installable
VMware vSphere ESXi 5.1
VMware vSphere ESXi 5.0
VMware vCenter Server 5.1.x
VMware ESXi 3.5.x Embedded
VMware vSphere ESXi 6.0
VMware vSphere ESXi 5.5
VMware vCenter Server 5.0.x
VMware ESXi 4.0.x Embedded
VMware vSphere ESXi 6.5
VMware ESXi 3.5.x Installable
VMware ESXi 4.0.x Installable
VMware ESXi 4.1.x Embedded
VMware vSphere ESXi 7.x

Cause

The issue may occur due to an older DLL file that is installed by some 3G USB data cards (bmnet.dll). This DLL is installed with the software suite.
 
This issue is seen to occur with, but is not restricted to, Sprint SmartView and AT&T Communications manager 3G software suites.

Resolution

To resolve this issue, try one of these options:
  • Remove the 3G software suite.
  • Install a newer version of the 3G software suite. This issue does not occur with latest versions of these third party suites.
  • Try removing the offending DLL with the LSP-Fix utility. This should not interfere with the functioning of the 3G data card.

     


Additional Information