When connecting the VMware vRealize Automation 6.0 Appliance to the Identity Appliance, you see the error: 'Error communicating to the remote server'.
search cancel

When connecting the VMware vRealize Automation 6.0 Appliance to the Identity Appliance, you see the error: 'Error communicating to the remote server'.

book

Article ID: 342179

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
When attempting to join the VMware vRealize Automation (formerly known as VMware vCloud Automation Center) Appliance to the VMware vRealize Automation (formerly known as VMware vCloud Automation Center) Identity Appliance, you see this error:

Error communication to the remote server https://[server name]:7444/sts/STSService/vsphere.local


Environment

VMware vCloud Automation Center for Desktop 6.0.x
VMware vCloud Automation Center for Server 6.0.x

Cause

There are multiple possible causes for this error:
  • The Identity Server does not contain the correct FQDN and port (7444) in the Host configuration tab.
  • The Identity Server and VMware vRealize Automation (formerly known as VMware vCloud Automation Center) Appliance are not time synced.
  • The certificate on the Identity Appliance has been rebuilt and includes the incorrect subject name.
  • The VMware vRealize Automation Appliance cannot reach the Identity Server by the specified FQDN and port.

Resolution

To resolve this issue, confirm these conditions:
  1. Verify DNS and Network connectivity between both servers.
  2. Both servers are time synched to the same NTP server(s).
  3. The Identity Server's Host name in the Identity server webpage is configured with it's correct FQDN and port (7444).
  4. Confirm and recreate the self-signed certificate on the VMware vRealize Automation Identity Appliance and confirm that you are using its FQDN for the subject name.