The VMware vRealize Automation Windows Guest Agent fails to process assigned jobs and the gugent-axis.log file reports the error: Client certificate chain file not specified
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The VMware vRealize Automation Windows Guest Agent fails to process assigned jobs and the gugent-axis.log file reports the error: Client certificate chain file not specified

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Article ID: 342112

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • The VMware vRealize Automation (formerly known as vCloud Automation Center) Windows Guest Agent fails to process assigned jobs.
  • Your Windows provisioning fails after a two hour timeout period.
  • In the gugent-axis.log file, located at c:\VRMGuestAgent\, you see errors similar to:

    [info] [ssl client] Client certificate chain filenot specified

    [error] ..\..\src\core\transport\http\sender\http_sender.c(1442) Error occurred in transport

    [error] ..\..\src\core\engine\engine.c(179) Transport sender invoke failed


  • From the preceding errors, you can see certificate failure.


Environment

VMware vCloud Automation Center for Server 5.2.x
VMware vCloud Automation Center for Server 6.0.x

Cause

This issue occurs due to these reasons:

  • An incorrect or corrupted certificate in the VRMGuestAgent folder on the guest operating system (OS). If a .PEM file exists with incorrect information, the Guest Agent does not pull down an updated certificate.
  • If you have installed the Guest Agent and pointed it to a VMware vRealize Automation (formerly known as vCloud Automation Center)/IaaS server that contains an invalid certificate.

Resolution

To resolve this issue when there is an incorrect or corrupted certificate in the VRMGuestAgent folder on the guest OS, delete the .PEM file located at C:\VRMGuestAgent\ directory in your Windows template or source virtual machine:

To delete the .PEM file:
  1. Stop the VRMGuestAgent service.
  2. Delete the .PEM file located at C:\VRMGuestAgent\ directory.
  3. Shut down the template or source virtual machine.
  4. Provision a new virtual machine from the template to confirm if the issue is resolved.
To update/confirm the FQDN name of the VMware vRealize Automation (formerly known as vCloud Automation Center) server that you are pointing to within the Windows Guest:
  1. Stop the VRMGuestAgent service.
  2. Delete the .PEM file located at C:\VRMGuestAgent\ directory.
  3. Uninstall the Guest Agent using an elevated command prompt and run this command:

    c:\VRMGuestAgent\winservice.exe -u.

  4. Install the Guest Agent using an elevated command prompt and run this command:

    c:\VRMGuestAgent\winservice.exe -i -h [vCAC Manager Service Server or IaaS FQDN]:443 -p ssl

  5. Shut down the template or source virtual machine.
  6. Provision a new virtual machine from the template to confirm if the issue is resolved.