VMware vRealize Automation tasks fail to time out causing inactive VMware vRealize Automation agent service
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VMware vRealize Automation tasks fail to time out causing inactive VMware vRealize Automation agent service

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Article ID: 341915

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • VMware VMware vRealize Automation (formerly known as vCloud Automation Center) tasks do not time out in the VMware vRealize Automation agent.
  • The VMware vRealize Automation agent queue fills up and the agent service becomes inactive.
  • If you reboot vCenter Server, the VMware vRealize Automation agent fails to reconnect.
  • The VMware vRealize Automation agent on the server shows the agent service running but the VMware vRealize Automation UI displays a Down status for the VMware vRealize Automation agent.
  • In the VMware vRealize Automation agent logs, all activity stops.
  • The VMware vRealize Automation agent service is on, active and performing data collections but it is unable to process workflows for disposing or provisioning until you restart the VMware vRealize Automation agent service.


Environment

VMware vCloud Automation Center for Desktop 5.1.x
VMware vCloud Automation Center for Server 4.5.x
VMware vCloud Automation Center for Server 5.1.x
VMware vCloud Automation Center for Desktop 5.2.x
VMware vCloud Automation Center for Server 6.0.x
VMware vCloud Automation Center for Server 5.2.x
VMware vCloud Automation Center for Desktop 6.0.x

Cause

This issue occurs when a CustomizeVM work item is issued from the VMware vRealize Automation agent to vCenter Server but there is no response. The VMware vRealize Automation agent waits for the response with no time out. The VMware vRealize Automation agent has a limit of 10 outstanding work items at the same time. When the limit is reached, the VMware vRealize Automation agent stops requesting work items from the VMware vRealize Automation Manager Service.

Resolution

This is a known issue affecting all versions of VMware vRealize Automation (formerly known as vCloud Automation Center). Currently, there is no resolution.

To work around this issue, restart the VMware vRealize Automation agent service manually.


Additional Information

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