Request is stuck at Pending Approval status in vRA 7.x
book
Article ID: 341864
calendar_today
Updated On:
Products
VMware Aria Suite
Issue/Introduction
Symptoms:
A request is stuck at Pending Approval status and does not have a valid approver in vRealize Automation (vRA).
Environment
VMware vRealize Automation 7.x
Cause
This issue occurs when:
- The approver for the request is no longer a member of the approvers group (no longer with the company).
- The approver was added to the approval group after the request was created.
Resolution
Prerequisites:
- You have valid snapshots or backups of the system before proceeding.
Procedure:
- Connect to vRealize Automation appliance through SSH using root credentials.
- Open Postgres as user postgres running the command:
/opt/vmware/vpostgres/9.4/bin/psql -U postgres
- Change to the vRA database:
\c vcac
- Enable expanded view:
\x
- Run the below command to check the details of work item to ensure this is the correct approval in question:
select * from work_item where workitemnumber=##;
where ## is the approval number
You should see it includes all the relevant information to process this request once approved.
- After verifying the right work item details, run the below command to change the status to "cancelled" :
update work_item set state=’CANCELLED’ where workitemnumber=##;
where ## is the approval number
After a UI refresh, you see that Pending Approval state is changed.
Feedback
thumb_up
Yes
thumb_down
No