Configuring the vSphere Data Protection (VDP) appliance results in the message: Could not connect to the requested VDP appliance
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Configuring the vSphere Data Protection (VDP) appliance results in the message: Could not connect to the requested VDP appliance

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Article ID: 341841

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

This article provides information about resolving SSO server configuration issues for the vSphere Data Protection (VDP) appliance.

Symptoms:
  • When configuring the vSphere Data Protection (VDP) appliance, you receive the message:

    Could not connect to the requested VDP appliance

  • The server FQDN or IP address for the Single Sign-On (SSO) server differs from vCenter Server
  • In the /usr/local/avamar/var/vdr/server_logs/vdr-server.log file, you see an entry similar to:

    YYYY-MM-DD HH:MM:SS,MS ERROR [com.abc.vdr.server.VDRServer$1]-server.VDRServer: VDRServer.getVCenterClient cannot obtain VCenterClient java.lang.NullPointerException: VCenterClient list is empty

  • Also in the vdr-server.log file, you may see an entry similar to:

    YYYY-MM-DD HH:MM:SS,MS INFO [http-xxxx-exec-x] -impl.X509TrustChainKeySelector: Failed to find trusted path to signing certificate


Environment

VMware vSphere Data Protection 5.5.x
VMware vSphere Data Protection 5.1.x

Cause

The confusion as to whether vCenter Server is using embedded SSO or a standalone SSO server causes many configuration issues with the VDP appliance. This error is caused because of a discrepancy in the SSL certificates from the Windows SSO server and the one with which the vCenter Server is communicating.

This issue can also occur when the date/time/year is not configured correctly on the VDP appliance causing an inconsistency between the appliance and the vCenter Server.

Resolution

To resolve this issue, you must enter the vCenter Server FQDN or IP address as the SSO server.

To determine if this issue is caused by the date/time/year configuration, run the date command and verify the output. Ensure the ESXi NTP configuration is set properly and can synchronize correctly.

If the output is out of synchronize, correct the time and date:

  1. To set the date, run the command:

    date +%Y%m%d -s "YYYYMMDD"

    Where YYYY is the 4-digit year, MM is the 2-digit month, and DD is the 2-digit day of the month.

  2. The time is reset after running the previous command, so set the current time by running the command:

    date +%T -s "HH:MM:SS"

    Where HH is the 2-digit hour (in 24-hour format), MM is the 2-digit minute, and SS is the 2-digit number of seconds.
Additional Information
This solution is limited in scope, but as a best practice when configuring the VDP appliance, enter the vCenter Server information as the SSO server unless the vCenter Server has specifically been configured to use a standalone SSO server.

Note: This issue can also occur when trying to connect to a VDP appliance deployed into a vCenter Server 5.0 environment. In this case, the authentication fails because SSO is not supported in vSphere 5.0. VMware Data Protection is only supported in vSphere 5.1 and requires vCenter Server 5.1 to function correctly.


Additional Information


vSphere Data Protection (VDP) アプライアンスを構成すると次のメッセージが表示される:要求された VDP アプライアンスに接続できませんでした (Could not connect to the requested VDP appliance)
配置 vSphere Data Protection (VDP) 设备时出现以下消息:无法连接到请求的 VDP 设备 (Could not connect to the requested VDP appliance)