This article provides information on how to detect and resolve the issue of spurious conflicting datastore error not allowing ESXi hosts to be reconnected to the vCenter server.
"Conflicting VMFS datastores (url ds:///vmfs/volumes/#####/) - one is backed by local disk"
"Datastore '#####' conflicts with an existing datastore in the datacenter that has the same URL (ds:///vmfs/volumes/#####/), but is backed by different physical storage."
This issue occurs in one of the following scenarios:
/var/log/vmware/vpxd.log on the vCenter Server, below entries are seen:YYYY-MM-DDTHH:MM:SS.289 info vpxd[09096] [Originator@6876 sub=InvtHostCnx opID=HeartbeatStartHandler-556#####] Host build number changed; [vim.HostSystem:host-#####,hostname.domainname], old: 20#####, new: 24#####
YYYY-MM-DDTHH:MM:SS.289 info vpxd[07213] [Originator@6876 sub=vpxLro opID=lro-200068693-62#####4] [VpxLRO] -- BEGIN lro-200068693 -- -- HostDisconnectAndReconnectLRO --
YYYY-MM-DDTHH:MM:SS.488Z info vpxd[04124] [Originator@6876 sub=MoHost opID=lro-699321-40#####] host [vim.HostSystem:host-#####,hostname.domainname] connection state changed to DISCONNECTEDYYYY-MM-DDTHH:MM:SS.496Z warning vpxd[04124] [Originator@6876 sub=MoCluster opID=lro-699321-40#####a] Deprecated property ClusterComputeResource.configuration readYYYY-MM-DDTHH:MM:SS.553Z error vpxd[04124] [Originator@6876 sub=HostAccess opID=lro-699321-40#####a] Conflicting VMFS datastores (url ds:///vmfs/volumes/#####/) - one is backed by local diskYYYY-MM-DDTHH:MM:SS.555Z info vpxd[04124] [Originator@6876 sub=vpxLro opID=lro-699321-40#####a-02] [VpxLRO] -- BEGIN lro-699325 -- -- DasConfig.UnconfigureHost --YYYY-MM-DDTHH:MM:SS.557Z info vpxd[04124] [Originator@6876 sub=vpxLro opID=lro-699321-40#####a-02] [VpxLRO] -- FINISH lro-699325YYYY-MM-DDTHH:MM:SS.557Z warning vpxd[04124] [Originator@6876 sub=MoHost opID=lro-699321-40#####a] Failed to Disconnect and Reconnect host [vim.HostSystem:host-#####,hostname.domainname]: N3Vim5Fault25ConflictingDatastoreFound9ExceptionE(Fault cause: vim.fault.ConflictingDatastoreFoundYYYY-MM-DDTHH:MM:SS.590Z info vpxd[04028] [Originator@6876 sub=Default opID=7cc9145] [VpxLRO] -- ERROR task-1229559 -- host-25 -- vim.HostSystem.reconnect: vim.fault.ConflictingDatastoreFound:--> Result:--> (vim.fault.ConflictingDatastoreFound) {--> faultCause = (vmodl.MethodFault) null,--> faultMessage = <unset>,--> name = "datastore-01",--> url = "ds:///vmfs/volumes/#####/"--> msg = ""--> }--> Args:--> /--> Arg cnxSpec:-->--> Arg reconnectSpec:-->
/etc/hosts file is configured with incorrect or out of order entries for the ESXi hosts.There is no resolution because this is due to individual DNS configuration.
Connect to the vCenter Server and correct the /etc/hosts file:
1. Connect to the VCSA through SSH or its virtual machine console and authenticate as the root user.
2. Examine the /etc/hosts file entry for the affected host(s).
# cd /etc/# cat hosts |less
Generally, for each device entry, the IP address is first, followed by the Fully Qualified Domain Name (FQDN), followed by the shortname.
Example:192.168.#.# myhost01.mydomain.com myhost01
/etc/hosts to resolve device IPs is unnecessary as DNS performs this function -- however, it might be used more frequently in VXRail environments. If there is any question about this in a VXRail environment, please contact Dell/EMC for support.3. If you see that the entry for the affected host is incorrect, edit the hosts file to fix the entry.
Note: Make a backup copy of the hosts file and then edit the file (# cp hosts hosts.bak)
# vi hosts:wq to save:q! if you've made a mistake and decide you want to start fresh.Note: This issue also occurs if ESXi hosts are added to the vCenter using shortname and the /etc/hosts file has entries added correctly as "192.168.#.# myhost01.mydomain.com myhost01". If this is the case, you need to modify the /etc/hosts file and remove the FQDN.
Example:
192.168.#.# myhost01
If the work-around does not work due to a different cause of the issue, contact VMware by Broadcom Support and note this KB in the problem description.
For more information, see How to Submit a Broadcom Support Request.
Impact/Risks:Affected ESXi hosts may not be able to be reconnected and managed by vCenter or are not able to be updated following the error.