"Conflicting VMFS datastores ... one is backed by local disk" error while reconnecting ESXi host to vCenter Server
search cancel

"Conflicting VMFS datastores ... one is backed by local disk" error while reconnecting ESXi host to vCenter Server

book

Article ID: 341652

calendar_today

Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

This article provides information on how to detect and resolve the issue of spurious conflicting datastore error not allowing ESXi hosts to be reconnected to the vCenter server.

A ESXi host is disconnected from the vCenter sever. Upon reconnection, you may see the following error messages :-

"Conflicting VMFS datastores (url ds:///vmfs/volumes/#####/) - one is backed by local disk"

"Datastore '#####' conflicts with an existing datastore in the datacenter that has the same URL (ds:///vmfs/volumes/#####/), but is backed by different physical storage."

This issue occurs in one of the following scenarios:

  • vCenter Server Appliance is upgraded from (VCSA) 6.7 U2 series to VCSA 6.7 U3 series
  • ESXi host is reconnected to vCenter server after the host is upgraded from ESXi 6.7 U2 to ESXi 6.7 U3
  • An ESXi host running 6.7 U2 host is manually disconnected from a vCenter server, and then connected again to the vCenter server.
  • ESXi hosts are upgraded.
  • In the /var/log/vmware/vpxd.log on the vCenter Server, below entries are seen:

YYYY-MM-DDTHH:MM:SS.289 info vpxd[09096] [Originator@6876 sub=InvtHostCnx opID=HeartbeatStartHandler-556#####] Host build number changed; [vim.HostSystem:host-#####,hostname.domainname], old: 20#####, new: 24#####

YYYY-MM-DDTHH:MM:SS.289 info vpxd[07213] [Originator@6876 sub=vpxLro opID=lro-200068693-62#####4] [VpxLRO] -- BEGIN lro-200068693 --  -- HostDisconnectAndReconnectLRO --

YYYY-MM-DDTHH:MM:SS.488Z info vpxd[04124] [Originator@6876 sub=MoHost opID=lro-699321-40#####] host [vim.HostSystem:host-#####,hostname.domainname] connection state changed to DISCONNECTED
YYYY-MM-DDTHH:MM:SS.496Z warning vpxd[04124] [Originator@6876 sub=MoCluster opID=lro-699321-40#####a] Deprecated property ClusterComputeResource.configuration read
YYYY-MM-DDTHH:MM:SS.553Z error vpxd[04124] [Originator@6876 sub=HostAccess opID=lro-699321-40#####a] Conflicting VMFS datastores (url ds:///vmfs/volumes/#####/) - one is backed by local disk
YYYY-MM-DDTHH:MM:SS.555Z info vpxd[04124] [Originator@6876 sub=vpxLro opID=lro-699321-40#####a-02] [VpxLRO] -- BEGIN lro-699325 --  -- DasConfig.UnconfigureHost --
YYYY-MM-DDTHH:MM:SS.557Z info vpxd[04124] [Originator@6876 sub=vpxLro opID=lro-699321-40#####a-02] [VpxLRO] -- FINISH lro-699325
YYYY-MM-DDTHH:MM:SS.557Z warning vpxd[04124] [Originator@6876 sub=MoHost opID=lro-699321-40#####a] Failed to Disconnect and Reconnect host [vim.HostSystem:host-#####,hostname.domainname]: N3Vim5Fault25ConflictingDatastoreFound9ExceptionE(Fault cause: vim.fault.ConflictingDatastoreFound
YYYY-MM-DDTHH:MM:SS.590Z info vpxd[04028] [Originator@6876 sub=Default opID=7cc9145] [VpxLRO] -- ERROR task-1229559 -- host-25 -- vim.HostSystem.reconnect: vim.fault.ConflictingDatastoreFound:
--> Result:
--> (vim.fault.ConflictingDatastoreFound) {
-->    faultCause = (vmodl.MethodFault) null,
-->    faultMessage = <unset>,
-->    name = "datastore-01",
-->    url = "ds:///vmfs/volumes/#####/"
-->    msg = ""
--> }
--> Args:
--> /
--> Arg cnxSpec:
-->
--> Arg reconnectSpec:
-->

Environment

  • VMware vCenter Server 6.7
  • VMware vCenter Server 7.x
  • VMware vCenter Server 8.x

Cause

  • This issue occurs if the vCenter's /etc/hosts file is configured with incorrect or out of order entries for the ESXi hosts.

Resolution

There is no resolution because this is due to individual DNS configuration.

Workaround:

Connect to the vCenter Server and correct the /etc/hosts file:

1. Connect to the VCSA through SSH or its virtual machine console and authenticate as the root user.
2. Examine the /etc/hosts file entry for the affected host(s).

# cd /etc/
# cat hosts |less

Generally, for each device entry, the IP address is first, followed by the Fully Qualified Domain Name (FQDN), followed by the shortname.

Example:
192.168.#.# myhost01.mydomain.com myhost01

    • In most environments, having entries in /etc/hosts to resolve device IPs is unnecessary as DNS performs this function -- however, it might be used more frequently in VXRail environments. If there is any question about this in a VXRail environment, please contact Dell/EMC for support.
    • Cases have been seen where the order of the hosts FQDN/shortname entries have got reversed or are showing a different FQDN than previously.

3. If you see that the entry for the affected host is incorrect, edit the hosts file to fix the entry.

Note: Make a backup copy of the hosts file and then edit the file  (# cp hosts hosts.bak)

  1. # vi hosts
  2. Use the INSERT key to go into edit mode.
  3. Fix the entries
  4. Use ESC key to exit edit mode.
  5. Use :wq to save
  6. Use :q! if you've made a mistake and decide you want to start fresh.

Note: This issue also occurs if ESXi hosts are added to the vCenter using shortname and the /etc/hosts file has entries added correctly as "192.168.#.# myhost01.mydomain.com myhost01". If this is the case, you need to modify the /etc/hosts file and remove the FQDN.

Example:

192.168.#.# myhost01

If the work-around does not work due to a different cause of the issue, contact VMware by Broadcom Support and note this KB in the problem description.
For more information, see How to Submit a Broadcom Support Request.

Additional Information

Impact/Risks:Affected ESXi hosts may not be able to be reconnected and managed by vCenter or are not able to be updated following the error.