"Device 'Bootstrap' is not available" error powering on a virtual machine
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Article ID: 341626
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Updated On: 05-16-2025
Products
VMware vCenter Server
VMware vSphere ESXi
Issue/Introduction
Symptoms:
- Powering on a virtual machine, you see the error:
Error An error was received from the ESX host while powering on VM vmname. Device 'Bootstrap' is not available.
- In the hostd.log, you see similar to:
017-02-02T17:07:56.590Z info hostd[3F581B70] [Originator@6876 sub=Libs opID=########-######2E-d85e user=root] OBJLIB-FILEBE : FileBEOpen: can't open '/vmfs/volumes/########-######87/vmpath/vm.vmdk' : Insufficient permission to access the file (458754)
Environment
VMware vCenter Server 7.x
VMware ESXi 7.x
Cause
This issue can be caused by:
- ESXi host that does not hold the lock on the VM files.
- ESXi host has insufficient access to underlying storage
- Bad data in the VM descriptor file (*.vmx)
Resolution
- Rule out file lock problems:
- Open an SSH session into the ESXi host where the virtual machine is registered to
- Follow this link to find out which ESXi host is holding the lock on any of the files that compose that virtual machine: Investigating virtual machine file locks on ESXi hosts
- Login to vCenter Server Web Client and set DRS to "Manual"
- Migrate the VM to the host identified in previous steps
- Power on VM
- Set DRS back to previous the Automation Level
- If there are no file lock issues found, or if you see insufficient permission to access the file in hostd.log, rule out datastore access problems:
- For NFS storage, check the NFS array manager software, to find out whether the following options are enabled:
root_squash
all_squash
- If so, these settings should be disabled. You may need your storage array vendor to assist with this
- For other storage types:
- Check that there are no errors on storage array manager
- Check whether you see input/output errors in the vmware.log, or if you get those errors when trying to access the VM's directory
- If there are I/O errors, restore or rebuild VM onto a healthier datastore
- Check that permissions to the host are adequate such as read/write is enabled
- May need to reset the affected LUN
- If you see evidence of permission problems but can't find the cause you may need to consult with your storage array vendor
- If there are no datastore access problems found, rule out bad data in the VM descriptor file (*.vmx)
- Manually rebuild a fresh VM:
- Right-click the VM and select Edit Settings...
- Take note of all VM settings
- Create a new VM with the same settings
- Attach the affected VM's virtual disks to the new VM
- Alternatively, you may follow Rebuilding the virtual machine's .vmx file from vmware.log which provides a script to automate rebuilding the *.vmx file
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