Virtual machine with multiple user login session fails with the error: GuestRpc: Channel X, conflict: guest application toolbox-dnd tried to register, but it is still registered on channel Y
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Virtual machine with multiple user login session fails with the error: GuestRpc: Channel X, conflict: guest application toolbox-dnd tried to register, but it is still registered on channel Y

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Article ID: 341602

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:

When multiple users are logged in an operating system, you may experience these symptoms:

  • Though registered on channe lX, the guest application toolbox-dnd tries to register but fails intermittently.
  • In the related virtual machine /vmfs/volumes/virtual_machine_datastore/virtual_machine/vmware.log file, you see entries similar to:

    <YYYY-DD-MM><time>| vcpu-0| I120: GuestRpc: Channel 4, conflict: guest application toolbox-dnd tried to register, but it is still registered on channel 2
    <YYYY-DD-MM><time>| vcpu-0| I120: GuestRpc: Channel 4, conflict: guest application toolbox-dnd tried to register, but it is still registered on channel 2
    <YYYY-DD-MM><time>| vcpu-0| I120: GuestRpc: Channel 4, conflict: guest application toolbox-dnd tried to register, but it is still registered on channel 2
    <YYYY-DD-MM><time>| vcpu-0| I120:GuestRpc: Channel X reinitialized.
    </time></time></time></time>

    Note: This message is not seen on single user virtual machines.

    Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.


Environment

VMware vSphere ESXi 5.5
VMware vSphere ESXi 5.1
VMware vSphere ESXi 6.0
VMware vSphere ESXi 5.0

Cause

This issue occurs when the VMware Tools daemon vmtoolsd, handles more than one user GUI login sessions. When a user connects to a virtual machine through the GUI, each user session has one vmusr process running. However, the second vmusr process cannot communicate with the vmx process because the channel initialization fails.

Resolution

This issue is resolved in:

To work around this issue, disable general virtual machine logging to the vmware.log file for the virtual machine:

  1. Click the virtual machine in the Inventory.
  2. In the Summary tab for that virtual machine, click Edit Settings.
  3. In the virtual machine Properties, click the Options tab.
  4. Under Advanced, click General and deselect Enable logging.
  5. Click OK to save the change.

    To make the change take effect, power off the virtual machine and power it on again. Reinstall VMware Tools, if the issue continues.

    Note: If you do not want to power off your virtual machine to disable logging, you can vMotion to migrate the virtual machine after changing this setting.



Additional Information