Captcha prompt is repeatedly displayed when logging in to vCenter Chargeback Manager as the admin user
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Captcha prompt is repeatedly displayed when logging in to vCenter Chargeback Manager as the admin user

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Article ID: 341462

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • When you have one or more vCloud Data Collectors installed, a captcha prompt is displayed repeatedly when logging in to Chargeback Manager as the admin user.
  • In the vCenterCB.log file, you see entries similar to:

    2013-01-30 04:33:43,140 ERROR [ajp-8009-1] impl.UserAuthenticationHandlerImpl 6783: User entered invalid captcha.
    2013-01-30 04:33:43,140 ERROR [ajp-8009-1] facade.CBMImpl 6783: An error occurred: Your account is locked. Please contact administrator or try after 30 minutes.

  • In the vCenter-DC.log file, you see entries similar to:

2013-01-26 23:19:33,299 ERROR [org.springframework.scheduling.timer.TimerFactoryBean#1] utils.ChargebackApiErrorHandler 1044: Failed to login the user admin into vCenter Chargeback Manager



Environment

VMware vCenter Chargeback Manager 2.0.x
VMware vCenter Chargeback Manager 2.5.x

Cause

This issue occurs if the vCloud Data Collector is configured with an incorrect password for the Chargeback Manager admin account.

Resolution

To resolve this issue:

  1. Log in to Chargeback Manger as the admin user.
  2. Click the Settings tab.
  3. Click Data Collectors.
  4. Click the VMware Cloud Director tab.
  5. Click the Change password for 'admin' for cloud data collectors link.
  6. Enter the correct password for the Chargeback Manager admin account.
  7. Click Change Password.
  8. Restart the VMware vCenter Chargeback - VMware Cloud Director Data Collector service.