Test Connection fails both Remote Registry and Perfmon tests
search cancel

Test Connection fails both Remote Registry and Perfmon tests

book

Article ID: 341401

calendar_today

Updated On:

Products

VMware

Issue/Introduction

  • Test Connection fails
  • The affected remote servers report the following errors when a Test Connection is run:
    • Registry reports: The network path was not found(53)
    • Perfmon reports: Unable to connect to specified machine or machine is offline (-2147481648)


Environment

VMware Capacity Planner 2.6.x
VMware Capacity Planner 2.1.x
VMware Capacity Planner 2.5.x

Resolution

This can happen if the Remote Registry is not running, not responding, or if the IPC pipe is blocked by a policy or registry change.
To troubleshoot this issue:
  1. Click Start > Control Panel > Administrative Tools > Services.
  2. Find the "Remote Registry" service. Ensure the Startup Type is set to Automatic and the Status is set to Started. Start the service or change the startup type to match these values.
  3. If the connection still fails, restart the "Remote Registry" service and try again.
  4. Check the Active Directory or domains for a policy blocking access to the Remote Registry service.
  5. Open the Registry Editor (regedit.exe ) and check the key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurePipeServers\winreg
    • If the key is missing, restore it by exporting a known good key from another server running the same operating system and service pack level. Restart the server.
  6. If the connection still fails, reboot any Active Directory domain controllers.
Note: If your problem still exists after trying the steps in this article, please:
  • File a support request with VMware Support and note this KB article ID in the problem description. For more information, see How to Submit a Support Request</u>.