Components and versions required to run Capacity Planner
search cancel

Components and versions required to run Capacity Planner

book

Article ID: 341398

calendar_today

Updated On:

Products

VMware

Issue/Introduction

This article outlines the component requirements to successfully install and run the Capacity Planner Collector.

Environment

VMware Capacity Planner 2.5.x
VMware Capacity Planner 2.6.x
VMware Capacity Planner 2.1.x

Resolution

This is a list of the minimum software versions and settings required to install and run Capacity Planner:

Software Packages / Operating Systems

  • Any of these operating systems:
    • Microsoft Windows 2000 Service Pack 3
    • Windows XP Professional (Service Pack 1 or higher recommended)
    • Windows Server 2003 with Hotfix 909139 or Service Pack 2 (recommended)
  • Microsoft Data Access Controls (MDAC) 2.41 or higher
  • Microsoft Joint Engine Technology (JET) 4.0 SP6 or higher (SP8 recommended)
  • Visual Basic 6 Run-time Libraries SP6 or higher
  • Windows Script Host 5.6 or higher
  • Internet Explorer 5.01 SP2 or higher

Configuration

  • Windows Installer service must be not be disabled
  • Login must have local Administrator rights
  • Windows 2003 Server Internet Explorer Enhanced Security must not</u> be installed.
  • Microsoft File and Printer sharing must be enabled
  • Microsoft NetBIOS over TCP/IP (NetBT) must be enabled
  • Windows Firewall should be disabled (recommended)

Services

The following services on the host must not be disabled for Windows collection to be successful:
  • Computer Browser
  • DCOM (Distributed Component Object Model) Server Process Launcher
  • DNS Client
  • Performance Logs and Alerts
  • Remote Procedure Call (RPC)
  • Remote Registry
  • Server
  • Windows Management Instrumentation (WMI)
  • Workstation