VMware Aria Operations displays incorrect time and/or date
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VMware Aria Operations displays incorrect time and/or date

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Article ID: 341388

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • In VMware Aria Operations, the time and date may display incorrectly in these fields:
    • Reports
    • Metrics
    • Notifications
  • The time fails to display correctly despite having the NTP server settings configured correctly.
  • In the analytics log file you see entries similar to:

    2015-09-17 08:53:08,335 WARN [P2P message reader for quotes(vRealize Ops Analytics-<UUID>:4918)<v4>:10002 on port 34,625 ] com.vmware.vcops.analytics.gemfire.GemfireCommunicator.beforeCreate - FORWARD_DATA_ALT_REGION region exceed the maximum number of entries. Rejecting put in region FORWARD_DATA_ALT_REGION

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.


Environment

VMware Aria Operations 8.x (formerly vRealize Operations)

Cause

This issue occurs when the NTP server settings were not configured during the initial setup and defaults to UTC time zone.

Resolution

To resolve this issue, update the /etc/localtime file to the correct city in the desired time zone.
  1. Log into the VMware Aria Operations admin UI as the local admin user.
  2. Click Take Offline under Cluster Status.
Note: Wait for Cluster Status to show as Offline.
  1. Log in to the desired node as root via SSH or Console.
  2. Delete the current localtime file by running this command:
rm /etc/localtime
  1. Get a list of the time zone locations and cities by running the following command, and noting the desired timezone location and city:
ls -l /usr/share/zoneinfo/
  1. Set the time zone by running this command:
ln -s /usr/share/zoneinfo/location/city /etc/localtime

Note: Replace location and city with the location and city noted in step 5.

Exampleln -s /usr/share/zoneinfo/America/city /etc/localtime
  1. Reboot the node for the changes to take effect.
  2. Repeat steps 3-7 on all desired nodes in the cluster.
  3. Log into the VMware Aria Operations admin UI as the local admin user.
  4. Click Bring Online under Cluster Status.
Note: Wait for the Cluster Status to show as Online.


Additional Information