Error: "The operation was aborted because this would exceed the stored virtual machine quota of the selected virtual datacenter" occurs during VM creation operations
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Error: "The operation was aborted because this would exceed the stored virtual machine quota of the selected virtual datacenter" occurs during VM creation operations

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Article ID: 341320

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Creation of a new VM fails with the error:

    The operation was aborted because this would exceed the stored virtual machine quota of the selected virtual datacenter "<virtual datacenter name>". 
    # new virtualmachine(s) would have been created, and the virtual datacenter is already using # of a limit of #.

    or

    "The operation was aborted because you would exceed your stored virtual machine quota. # new virtual machine(s) would have been created, and your are already using # of a limit of #" when creating a new virtual machine.
  • Syncing a subscribed catalog from a published catalog will fail as VMs cannot be created within the virtual datacenter (VDC).

Environment

VMware Cloud Director 10.6.1

Cause

This issue will occur when a configured VM resource quota is exceeded. 
 
VM quota can be configured on an Organization, a Virtual Datacenter (VDC) and also on individual users profiles.

Resolution

This is expected behavior in Cloud director when a VM quota has been configured.

In order to resolve this issue, review the configured VM quota settings. 

    1. Within the Provider UI navigate to 'Resources -> Cloud Resources -> Organizations -> [Organization Name]'. 
      1. Navigate to 'Configure -> Quotas' and review if a setting named 'All VMs quota' is configured with a limit applied.

    2. Within the Provider UI navigate to 'Resources -> Cloud Resources -> Organization VDCs -> [VDC name]'.
      1. Click on 'Allocation'.
      2. Review the configured 'Maximum number of VMs' value.

    3. If the VM quota limit was not identified from steps 1 or 2 above, then you can additionally review any VM quota limit which has been applied on individual users. 
      1. Within the Tenant UI navigate to 'Administration -> Access Control -> Users'.
      2. Click the username of the user encountering the issue.
      3. Select 'Quotas' and review the 'All VMs quota' setting to confirm if any limit is applied.

Based on your inspection of the VM Quota settings configured in the environment, increase the VM Quota limit(s) to an appropriate value to allow for the creation of additional VMs. Alternatively you can review your existing VM inventory to see if there are any VMs which can be removed from the environment, therefore allowing new VMs to be created within the existing VM quota settings.