vm-support fails to collect the VM information using vSphere Web Client/vSphere Client (HTML5)/Host Client
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vm-support fails to collect the VM information using vSphere Web Client/vSphere Client (HTML5)/Host Client

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Article ID: 341186

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:

In the errors-ignored.log, you see error messages similar to: 

Execution of action "<action cmd="vmfile" options="IGNORE_MISSING,IGNORE_ERROR" path="*.cfg">" raised exception of type "UnicodeDecodeError": 'ascii' codec can't decode byte 0xe3 in position ####: ordinal not in range(128)

Execution of action "<action cmd="vmfile" options="IGNORE_MISSING,IGNORE_ERROR,MAXSIZE" path="*.dsk">" raised exception of type "UnicodeEncodeError": 'ascii' codec can't encode characters in position 50-53: ordinal not in range(128)



If you try to get vm-support via vsphere webclient/host client, vm-support log bundle may not include following VM file information.

- vm-flat.vmdk
- vm.vmkd
- vm.vmsd
- vm.vmx
- vmware.log

These are just examples, as other files may also not be collected.

Environment

VMware vSphere ESXi 6.5
VMware vSphere ESXi 7.0.0
VMware vSphere ESXi 6.7

Cause

If multi-byte UTF-8 characters are used in the annotation of a VM, vm-support may fail to collect the VM information when it was triggered from vSphere Web Client/vSphere Client (HTML5)/Host Client.

Resolution

VMware is aware of this issue.
A part of this issue is fixed in ESXi 6.5 Update 2, but there is still the problem of multi-byte UTF-8 characters.

Workaround:
To workaround, this issue use vm-support command or remove multi-byte UTF-8 characters from the VM annotation.

OR

Use the vm-support command on ESXi hosts via SSH client.

Additional Information

Editing virtual machine and host custom attributes, notes and annotations (1005720)
“vm-support” command in ESX/ESXi to collect diagnostic information (1010705)