VR server state shows as Disconnected in vSphere Web Client
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VR server state shows as Disconnected in vSphere Web Client

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Article ID: 341172

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Updated On:

Products

VMware Live Recovery VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • When navigating to the Web Client > vSphere replication > Manage > Replication Servers, VR server shows as disconnected.
  • Replications to this HBR change to RPO violation.
  • Unable to configure new replications.
  • In the hms.log file, you see entries similar to:

    2017-05-09 09:44:41.732 ERROR hms.net.hbr.ping.svr.520d4a7e-6469-abfa-9e1d-85b5dec7c18d [Ping Thread for server 127.0.0.1:8123] (..net.impl.VmomiPingConnectionHandler) | Ping for server 127.0.0.1:8123 failed: com.vmware.vim.vmomi.client.exception.ConnectionException: java.net.ConnectException: Connection refused (Connection refused) : java.net.ConnectException: Connection refused (Connection refused)

    Where 127.0.0.1 is the embedded VR server

    If there is an add on server, the IP will change accordingly

    Running the curl command to the IP on port 8123 fails

    # curl -v telnet://127.0.0.1:8123 * About to connect() to 127.0.0.1 port 8123 (#0) * Trying 127.0.0.1... Connection refused * couldn't connect to host * Closing connection #0 curl: (7) couldn't connect to host


    Note: This log excerpt is an example. Date, time, and environmental variables may vary depending on your environment.


Environment

VMware vSphere Replication 6.0.x
VMware vSphere Replication 6.1.x

Cause

This is a known issue affecting 6.0.x , 6.1.0 and 6.1.1 when SIOC is enabled on the datastores.
When SIOC is enabled on the datastore, there are multiple DatastorePropertyCallback alerts to HBRSRV and it may run out of resource to handle connection.

Resolution

This issue is resolved in vSphere 6.0 U3, ESXi 6.0 U3, and vSphere replication 6.1.2.

If upgrade is not feasible, perform this workaround:
  1. Disable SIOC on all the datastores.
  2. Reboot the PSC and vCenter Server.
  3. SSH to the Replication appliance and rename the /etc/vmware/hbrsrv.54.db file.
  4. Reboot the vSphere replication appliance.
  5. Perform step 4 and 5 for any add on servers.


Additional Information

Impact/Risks:
Renaming the file in the workaround stops the current replications and you will need to reconfigure them in the Web Client > vSphere Replication > Monitor.
You can also deploy an add on server and move the replication to the new add on before making the changes in the workaround.