Service Discovery Authentication fails after changing guest credentials in VMware Aria Operations 8.x
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Service Discovery Authentication fails after changing guest credentials in VMware Aria Operations 8.x

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Article ID: 341163

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • Service Discovery Authentication fails for a VM that was once working, after the guest credentials changed.


Environment

VMware vRealize Operations 8.x

Cause

This issue is caused when the previously used credentials were the root user or a full Administrator user, and have since been changed to another user in VMware Aria Operations (formerly known as vRealize Operations).

Resolution

To resolve this issue, clear the instance ID folder from the guest VM.
  1. Log into the guest VM as an administrative user.
  2. Delete the following folder:
Linux:
/tmp/VMware-SDMP-Scripts-instanceID-instanceUUID

Windows:
C:\Temp\VMware-SDMP-Scripts"-instanceID-instanceUUID

The agent should authenticate correctly on the next collection cycle and resume collections.


Additional Information

Impact/Risks:
This issue impacts all credential-based authentication methods (for both guest alias and common credentials)

Note: This article is not applicable for credential-less Service Discovery.