Error: "NMI watchdog: BUG: soft lockup - CPU#X stuck for XXs!" on console
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Error: "NMI watchdog: BUG: soft lockup - CPU#X stuck for XXs!" on console

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Article ID: 341140

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

When creating a snapshot of the vCenter Appliance or deploying a VCHA configuration, CPU-related errors may appear on the VCSA console similar to the following:

[2989.634241] NMI watchdog: BUG: soft lockup - CPU#0 stuck for 42s! [jsvc:8372]
[2989.634244] NMI watchdog: BUG: soft lockup - CPU#1 stuck for 44s! [jsvc:6612]
[18817.970155] NMI watchdog: BUG: soft lockup - CPU#1 stuck for 29s! [vmware-cis-lice:29462]

Environment

  • VMware vCenter Server Appliance 6.5.x
  • VMware vCenter Server Appliance 6.7.x
  • VMware vCenter Server Appliance 7.0.x
  • VMware vCenter Server Appliance 8.0.x

Cause

These kernel logs report a vCPU stall, indicating it was not scheduled for execution for N seconds.

Resolution

This message can be safely ignored and shouldn't cause issues on the vCenter Appliance if the timeout is within the acceptable range.

Workaround

The most common cause of this could be that the system is stunned or experiencing very high latency. Check the following to verify:

  • Storage performance
  • Snapshot commit performance
  • CPU values for both ESXi and a vCenter Virtual Machine.