Cannot access the LUN on EMC Clariion storage as it is marked as a deactivated snapshot
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Cannot access the LUN on EMC Clariion storage as it is marked as a deactivated snapshot

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Article ID: 341056

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

If you are using a EMC CLARiiON storage array and your ESX host is rebooted, you may experience these symptoms:
  • You cannot access LUNs
  • The LUNS are marked as deactivated snapshots
  • All affected LUNs show up in the multipath output:
    • VMFS5 / VMFS6 datastores do not mount.
    • RDM LUNs are inaccessible to the guest operating system they are presented to. They are reported as Unallocated in the computer management view.
       
      2013-03-27T15:03:04.905Z cpu3:2674)NMP: nmp_ThrottleLogForDevice:2318: Cmd 0x28 (0x41240075a480, 2095893) to dev "naa." on path "vmhba3:C0:T1:L14" Failed: H:0x0 D:0x2 P:0x2 Possible sense data: 0x5 0x25 0x1. Act:NONE

      The SCSI sense code returned in all of these examples can be translated to:

      Device D:0x2 = Check Condition
      Plugin P:0x2 = VMK_SCSI_PLUGIN_SNAPSHOT
      Sense 0x5 = Illegal Request
      ASC/ASQ = 25/01 = LOGICAL UNIT NOT SUPPORTED - Command was directed to an un-activated snapshot

      For more information on SCSI sense codes see: Understanding SCSI host-side NMP errors/conditions in ESXi.
       
      In ESXi 8.x vmkernel logs, we see "SCSI LUN is in snapshot state" below errors :




  • The option LVM.DisallowSnapshotLun is set to 1 (the default). Changing it to 0 and performing a rescan does not return visibility to the content of the LUNs.
  • The Navisphere manager reports that there are snapshots sessions of a source LUN in place and some of them are currently inactive.

Environment

ESXi 7.x
ESXi 8.x and later

Cause

ESXi is pointing to point-in-time copy ( de-activated snapshot) rather than its original lun.

Resolution

To access a LUN that is marked as a deactivated snapshot:

  1. Go to the Navisphere Manager and activate the inactive SnapView sessions. Wait until the SnapView reports those sessions as Active.
  2. Remove the RDM from the Windows virtual machines.
  3. Perform a rescan on the ESX host.
  4. Add the RDM back to the virtual machines.
  5. Power on the virtual machine.
  6. Perform a rescan form the Computer management view, if necessary. The RDMs come up as available and NFTS formatted. Full data access.