Troubleshooting a vCenter Converter snapshot process that fails to initialize
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Troubleshooting a vCenter Converter snapshot process that fails to initialize

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Article ID: 340980

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:
  • The vCenter Converter conversion process fails at 1%.
  • Snapshot processes do not initialize.
  • Snapshot process fails.
  • You may receive one or more of these errors:
    • Failed to take snapshot of the source volume
    • stcbasic.sys not installed or snapshot creation failed. err=2
    • Error opening disk device: Incorrect function (1)
    • Failed to get capacity for \\.\PhysicalDrive0 : error opening disk device: Incorrect function (1)
    • sysimage.fault.OsVersionNotFound
    • Warning: no attached disks were detected.
    • The COM Server with CLSID {65ee1dba-8ff4-4a58-ac1c-3470ee2f376a} and name SW_PROV cannot be started. [0x80070422]
    • vsnap does not have admin rights

  • When trying to use vcenter converter to p2v a windows physical server into our virtual infrastructure, we do not see the local disks but are able to see the remote drives.
  • The same issue occurred when tried with the 5.5 and 6.0 converter release.

  • In the Converter Agent logs, located at %ALLUSERSPROFILE%\VMware\VMware vCenter Converter Standalone Agent\logs\vmware-converter-agent-1.log file you may see:
    2015-08-21T09:30:29.778-04:00 [36544 info 'Default'] Could not find the session object cache, will create a new one
    2015-08-21T09:30:29.798-04:00 [36544 warning 'Default'] Failed to get capacity for \\.\PhysicalDrive0: error opening disk device: The process cannot access the file because it is being used by another process (32)
    2015-08-21T09:30:29.798-04:00 [36544 warning 'Default'] Skipping hard disk '\\.\PhysicalDrive0'
    2015-08-21T09:30:29.798-04:00 [36544 warning 'Default'] Failed to get capacity for \\.\PhysicalDrive1: error opening disk device: The process cannot access the file because it is being used by another process (32)Default'] [LiveWindowsComputer] Unable to find any disks attached to the computer.

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.


Environment

VMware vCenter Converter 4.1.x
VMware vCenter Converter Standalone 5.5.x
VMware vCenter Converter 4.0.x
VMware Converter 3.0.x
VMware vCenter Converter Standalone 5.0.x
VMware vCenter Converter Standalone 4.0.x
VMware vCenter Converter Standalone 4.3.x
VMware vCenter Converter 4.2.x

Cause

This issue is caused if we use Products like Altiris Client Management Suite or HP Insight Manager.

Resolution

Validate that each troubleshooting step below is true for your environment. The steps will provide instructions or a link to a document, for validating the step and taking corrective action as necessary. The steps are ordered in the most appropriate sequence to isolate the issue and identify the proper resolution. Do not skip a step.
  1. Verify that the Converter Agent is running and working correctly on the source server. For more information, see Ensuring proper installation of vCenter Converter and functionality of the Converter Agent (1006603).

  2. Verify that the failure is not due to an operating system problem on the source server (particularly Volume Shadow Copy services, if applicable). For more information, see Troubleshooting damaged operating system components that can cause conversion failures with vCenter Converter (1006489).

Note: If your problem still exists after trying the steps in this article, please file a support request with VMware Support and note this KB Article ID in the problem description. For more information, see How to Submit a Support Request.

TSE Note: We see this issue if we use Products like Altiris Client Management Suite or HP Insight Manager. By disabling these products or non Microsoft products on the Physical machine which we are trying to convert, will fix the issue and the converter will be able to detect the local disks.