SRM recovery fails to power on virtual machines with this error: A general system error occurred: Connection refused
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Article ID: 340454
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Updated On:
Products
VMware Live Recovery
Issue/Introduction
Symptoms:
- State of virtual machines on source site is shutdown
- Virtual machine are registered to destination site, however, is not powered on
- In the vmware-dr.log file on destination SRM server, you see entries similar to:
2017-08-26T15:50:51.707-05:00 [04252 verbose 'Recovery' ctxID=64db8b12 opID=24206ea5] Disconnect called for FailoverStepTracker, plan: ########-####-####-####-########757d
2017-08-26T15:50:51.707-05:00 [04252 info 'DrTask' ctxID=64db8b12 opID=24206ea5] Task 'dr.recovery.RecoveryManager.failover147' failed with error: (vmodl.fault.SystemError) {
--> faultCause = (vmodl.MethodFault) null,
--> reason = "Connection refused",
--> msg = "A general system error occurred: Connection refused"
Note: This log excerpt is an example. Date, time, and environmental variables may vary depending on your environment.
- Powering ON virtual machine manually on destination vCenter Server fails with this error:
A general system error occurred: Connection refused
- The same virtual machine can be powered on from the vSphere Client connected to the ESXi host
Environment
VMware Site Recovery Manager 6.0.x
VMware Site Recovery Manager 6.1.x
Cause
This issue occurs when VMware vCenter workflow manager service is not running on destination vCenter Server.
Resolution
To resolve this issue, start the VMware vCenter workflow manager service on vCenter Server
Windows vCenter Server
- Connect to vCenter Server, open Start > Run, type services.msc, and press Enter.
- Right-click VMware vCenter workflow manager service and click Start.
vCenter Server Appliance (VCSA)
- Establish SSH session to vCenter appliance.
- Run these commands to restart vCenter workflow manager service:
service-control --stop vmware-vpx-workflow
service-control --start vmware-vpx-workflow
Site Recovery Manager
- Once workflow manager is started, attempt to power on virtual machine in vCenter Server and ensure that there are no errors.
- Power off virtual machine and re-run recovery plan in SRM.
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