Appstacks appear to be disabled and unprovisioned after a rescan
search cancel

Appstacks appear to be disabled and unprovisioned after a rescan

book

Article ID: 340417

calendar_today

Updated On:

Products

VMware

Issue/Introduction

Symptoms:
After running an appstack rescan, you experience these symptoms:
  • Appstacks appears as disabled
  • Appstacks appears as unprovisioned in the manager UI


Environment

VMware App Volumes 2.11.x
VMware App Volumes 2.12.x
VMware App Volumes 2.10.x

Cause

  • This issue occurs when  a separate AppVolumes deployment is configured to use the same datastore 
  • This is not supported
  • AppVolumes modifies the metadata of appstacks, When rescanning, the system reads the metadata of the appstacks on the datastore and reflects the changes in UI.

Resolution

To resolve the issue, change the configuration of the second AppVolumes deployment to point to another path on the datastore, use another datastore, or stop the service/server.
 
To prevent the issue from recurring, move the appstacks on the production datastore to a different path on the datastore, import them, and recreate the assignments.


Additional Information

再スキャン後に Appstack が無効でプロビジョニングされていないように見える