"Connection refused" error when opening Management portal after deploying VIC 1.0 or 1.1
search cancel

"Connection refused" error when opening Management portal after deploying VIC 1.0 or 1.1

book

Article ID: 340336

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • After deploying VIC 1.1.0 and 1.1.1 appliance, logging in to management portal (Admiral) at port 8282 fails.
  • In the Browser, you see the error:

    The connection is refused
  • The Admiral logs reports error similar to:

    "algid parse error, not a sequence"


Environment

VMware vSphere Integrated Containers 1.0.x

Cause

This issue occurs when you deploy the OVA with incorrectly generated custom certificate key that you specify in OVA template.

Resolution

To resolve this issue, ensure that the certificate key is in PKCS8 format for Admiral.
 
Note: Admiral does not support any other format.