Host profile compliance check fails with the error: A permission for user or group does not exist
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Host profile compliance check fails with the error: A permission for user or group does not exist

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Article ID: 340221

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:

  • Cannot perform a host profile compliance check in vSphere 5.x
  • When a user or group permission is configured via the host profile editor, the compliance check fails
  • The user or group permission is available in the ESXi host.
  • You see the error:

    A permission for user or group <user/group> does not exist

 

Environment

VMware vCenter Server 5.1.x
VMware vSphere ESXi 5.1

Cause

This issue occurs if the user or group name consists of uppercase letters. The ESXi host converts the user or group name to lowercase, which does not match the originally entered name in the host profile.

Resolution

This is a known issue affecting vSphere 5.1.
 
To work around this issue, enter the domain name in uppercase and username in lowercase:
  1. Right-click the host and click Host Profile.
  2. Navigate to Permission policy.
  3. Change username case to match DOMAIN\user, where domain is in uppercase, and username is in lowercase.

Additional Information

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