Endpoint Operations adapter is in No Data receiving status in vRealize Operations 8.1.1
search cancel

Endpoint Operations adapter is in No Data receiving status in vRealize Operations 8.1.1

book

Article ID: 340097

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • The Endpoint Operations adapters are in a No Data Receiving status in vRealize Operations 8.1.1.


Environment

VMware vRealize Operations 8.1.x

Cause

This issue is caused by a regression in vRealize Operations 8.1.1.

Resolution

To resolve this issue, contact VMware Support to receive a patch that will resolve this, and other known issues.

Workaround:
Note: It is recommended to install the patch provided by VMware support.  If a patch is not able to be installed at this time, the below workaround can be utilized.

To successfully connect the Endpoint Operations agent to the vRealize Operations cluster, add the allowedRequestAttributesPattern=".*" entry to /usr/lib/vmware-vcops/tomcat-enterprise/conf/server.xml on all nodes in the cluster.
  1. Log into the Primary node as root via SSH or Console, pressing ALT+F1 in a Console to log in.
  2. Back up the server.xml file:
cp /usr/lib/vmware-vcops/tomcat-enterprise/conf/server.xml /tmp/server.xml
  1. Open /usr/lib/vmware-vcops/tomcat-enterprise/conf/server.xml in a text editor.
  2. Add allowedRequestAttributesPattern=".*" at the end of the <Connector port="${jk.port}" block.
Example:
....
<Connector port="${jk.port}"
           address="127.0.0.1"
           protocol="AJP/1.3"
           maxPostSize="-1"
           maxSavePostSize="-1"
           packetSize="65536"
           redirectPort="${bio-ssl.https.port}"
           secretRequired="false"
           URIEncoding="UTF-8"
           allowedRequestAttributesPattern=".*"/>
...
  1. Save and close the file.
  2. Run the following command to restart the API service:
/usr/bin/systemctl restart api
  1. Repeat steps 1-6 on all nodes in the cluster, including remote collectors.


Additional Information

To revert the changes from the Workaround, complete the following:
  1. Log into the Primary node as root via SSH or Console, pressing ALT+F1 in a Console to log in.
  2. Restore the server.xml file from backup:
mv /tmp/server.xml /usr/lib/vmware-vcops/tomcat-enterprise/conf/server.xml
  1. Run the following command to restart the API service:
/usr/bin/systemctl restart api
  1. Repeat steps 1-3 on all nodes in the cluster, including remote collectors.