Discovery Server issues related to performance / inaccuracy or exceeds 75% JVM RAM ( message in the discovery_server.log)
search cancel

Discovery Server issues related to performance / inaccuracy or exceeds 75% JVM RAM ( message in the discovery_server.log)

book

Article ID: 34005

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

- Node count inaccuracy in OC

- discovery _server slowness / performance issues

- cannot perform any discovery of snmp devices, although the snmp communication string given by device is already successfully tested by 3rd party MIB Browser 

Errors in discovery log:

WARN com.nimsoft.discovery.server.probe.ProbeInitializer - Waiting initialize UDM. Retrying java.lang.IllegalArgumentException db.error/not-enough-memory datomic.objectCacheMax datomic.memoryIndexMax exceeds 75% JVM RAM node count off not accurate discover systems robots nodes inaccurate

Environment

Component: discovery_server

Cause

  • Discovery memory too low 

Resolution

  1. Select the discovery_server probe.
  2. Hold down the SHIFT key then rt-click to select Raw Configure.
  3. Select startup->opt section.
  4. See startup->options java min and max. Set them to at least 2048 and 4096 respectively and cold start the discovery_server.

    5. Also make sure the correlation settings are set to true, especially for vm_id and robot_device_id.

   6. Then click Ok.

   7. Cold start the discovery_server probe: Deactivate, then Activate it