High number of "snmpd: lookup_vswitch: fetch VSI_MODULE_NODE_PortCfgs_properties failed Not found" messages in syslog.log
search cancel

High number of "snmpd: lookup_vswitch: fetch VSI_MODULE_NODE_PortCfgs_properties failed Not found" messages in syslog.log

book

Article ID: 339994

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Syslog servers and syslog.log file show continuous "snmpd: lookup_vswitch: fetch VSI_MODULE_NODE_PortCfgs_properties failed Not found" messages for ESXi hosts.

[YYYY-MM-DDTHH:MM:SS] snmpd: lookup_vswitch: fetch VSI_MODULE_NODE_PortCfgs_properties failed Not found
[YYYY-MM-DDTHH:MM:SS] snmpd: lookup_vswitch: fetch VSI_MODULE_NODE_PortCfgs_properties failed Not found
[YYYY-MM-DDTHH:MM:SS] snmpd: lookup_vswitch: fetch VSI_MODULE_NODE_PortCfgs_properties failed Not found
[YYYY-MM-DDTHH:MM:SS] snmpd: lookup_vswitch: fetch VSI_MODULE_NODE_PortCfgs_properties failed Not found

Environment

VMware vSphere ESXi 6.x
VMware vSphere ESXi 7.x
VMware vSphere ESXi 8.x

Cause

This is caused when the ESXi host's syslog logging level is set above WARNING level.

To verify this is the issue, you may check the current setting from the ESXi host command line with the following command:

# esxcli system snmp get

 

These messages are informational and do not present a risk to production services.

An explanation of the available logging levels is available in the KB below:

Increasing VMware vCenter Server and VMware ESXi logging levels

Resolution

To change the syslog logging level, set the logging level to WARNING with the following command:

# esxcli system snmp set -l warning

If you wish to maintain a higher level of logging but do not wish to see these warnings, consider filtering your syslog messages referring to the KB below:

Filtering logs in VMware vSphere ESXi