vRealize Log Insight UI does not fully load
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vRealize Log Insight UI does not fully load

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Article ID: 339894

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • Some elements of the vRealize Log Insight UI fail to load 
  • Only the navigation tabs at the top of the UI are visible
  • The above symptoms are true in a private browser mode
  • You may see similar entries in the /storage/var/loginsight/smtp_error.txt file with non-printable characters 
���������������������������������������������������������������������������������������������������������������[2022-04-23 12:56:10.240+0000] Failed to send e-mail to  with subject "Log Insight Admin Alert: Disk Space Usage Has Reached 75%". Reason: Sending the email to the following server failed 
 


Environment

VMware vRealize Log Insight 8.x

Cause

When the smtp_error.txt file contains NUL characters, it causes HTML corruption when the file is accessed to display SMTP warnings

Resolution

This is a known issue affecting vRealize Log Insight 8.x, there is no resolution at this time.  Please subscribe to this article to be informed when updates are published.

Workaround:
  1. SSH to the vRealize Log Insight primary node as root
Note: If you need to reset the root password, please refer to How to reset the root password in vRealize Log Insight (53649)
  1. Navigate to the /storage/var/loginsight/ directory 
cd /storage/var/loginsight/
  1. Using a text editor, open the smtp_error.txt file
  2. Locate and remove the NUL (non-printable) characters 
Example:
  • ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^
  • NUL NUL NUL NUL NUL NUL NUL NUL NUL NUL NUL NUL NUL NUL NUL 
  • ��������������������������������������
  1. Save and close the file
  2. Refresh the UI to verify functionality has returned