"Another application is using port 443. Use another port or remove the application that is using it" error while installing or validating Manager service
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"Another application is using port 443. Use another port or remove the application that is using it" error while installing or validating Manager service

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Article ID: 339758

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • You cannot install vRealize Automation IaaS Manager Service manually or by install wizard on a Windows server that has web software already installed.
  • You cannot install vRealize Automation IaaS Manager Service manually or by install wizard on a Windows server that had vRealize Automation Manager Service previously installed.
  • You see an error similar to:

    Command Result:
    Message:
    Another application is using port 443. Use another port or remove the application that is using it.

    Description
    Executing netsh http show sslcert ipport=0.0.0.0:443
    SSL Certificate bindings:
    -------------------------

    IP:port : 0.0.0.0:443
    Certificate Hash : a45fb0034dcd1028054b4da4ec834443126577da
    Application ID : {adb46c0e-7210-4f23-b7ea-172e99643129}
    Certificate Store Name : (null)
    Verify Client Certificate Revocation : Enabled
    Verify Revocation Using Cached Client Certificate Only : Disabled
    Usage Check : Enabled
    Revocation Freshness Time : 0
    URL Retrieval Timeout : 0
    Ctl Identifier : (null)
    Ctl Store Name : (null)
    DS Mapper Usage : Disabled
    Negotiate Client Certificate : Disabled


    Output:
    None




Environment

VMware vRealize Automation 7.2.x
VMware vRealize Automation 7.3.x

Cause

This issue occurs due to any of these reasons:
  • When port 443 has already been bound to an SSL certificate.
  • When you have uninstalled vRealize Automation IaaS Manager Service from a server and are attempting to reinstall it.

Resolution

To resolve this issue, remove the SSLCert binding from the port.

To remove the SSLCert binding from the port:

  1. Connect to the Manager Service server(s) remotely or through console.
  2. Open an Admin elevated command prompt.
  3. Run this command:

    netsh http delete sslcert ipport=0.0.0.0:443


Additional Information

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