Log Insight daemon fails to start after changing the hostname
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Log Insight daemon fails to start after changing the hostname

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Article ID: 339741

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Updating the config file with the correct hostname resolves the issue.

Symptoms:
  • Log Insight service status shows daemon not running with message:

    loginsight:~ # service loginsight status

    16/10/12 18:38:26 INFO executor.ProcessExecutor: Finished executing ip -4 addr show eth0, ran for 73 ms

    daemonNotRunning
  • Log Insight service fails to start.
  • Attempting to start the Log Insight service fails with the error:

    loginsight:~ # service loginsight start

    16/10/12 18:40:46 INFO executor.ProcessExecutor: Finished executing ip -4 addr show eth0, ran for 67 ms

    Starting Log Insight...

    [2016-10-12 18:40:47.113+0000] [Thread-5/192.168.1.12 INFO] [com.vmware.loginsight.commons.executor.ProcessExecutor] [Finished executing /usr/lib/loginsight/application/sbin/loginsight-daemon.sh -Xmx4000m -XX:MaxPermSize=128m --wait=120, ran for 888 ms]

    daemonConfigurationException

  • In the /storage/var/loginsight/loginsight_daemon_stdout.log file, you see message similar to:

    Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=128m; support was removed in 8.0
    16/10/12 18:44:53 INFO executor.ProcessExecutor: Finished executing ip -4 addr show eth0, ran for 62 ms
    log4j:WARN No appenders could be found for logger (com.vmware.loginsight.commons.executor.ProcessExecutor).
    log4j:WARN Please initialize the log4j system properly.
    log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
    loginsight.vpn.hn2.org cannot be resolved and there is not master IP buffer
    Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=128m; support was removed in 8.0
    16/10/12 18:47:20 INFO executor.ProcessExecutor: Finished executing ip -4 addr show eth0, ran for 78 ms
    log4j:WARN No appenders could be found for logger (com.vmware.loginsight.commons.executor.ProcessExecutor).
    log4j:WARN Please initialize the log4j system properly.
    log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
    loginsight.vpn.hn2.org cannot be resolved and there is not master IP buffer


Environment

VMware vCenter Log Insight 2.x
VMware vCenter Log Insight 1.x

Cause

This issue occurs due to incorrect hostname in the configuration file.

Resolution

To resolve this issue, update the config file with the correct hostname.

To update the config file:

Note: Do not use this method in Log Insight 3.0 and later. For more information, see Changing internal configuration options in VMware vRealize Log Insight (2123058).
  1. Open a console or SSH connection to the Log Insight appliance and login as root.
  2. Change to the Log Insight configuration directory by running this command:

    cd /storage/core/loginsight/config

  3. Find the configuration file with the highest version number. For example:

    ls -1v log*

    loginsight-config.xml#10

    loginsight-config.xml#11

    loginsight-config.xml#12

  4. Make a temporary copy of the latest configuration file.

    For example:

    cp loginsight-config.xml#12 temporary.xml

  5. Open the temporary copy of the configuration file using a text editor.
  6. Locate the desired section within the <config> file.
  7. Change and update the hostname accordingly.
  8. Save the configuration file.
  9. Move the temporary configuration file, naming it the next highest sequence number.

    For example:
    mv temporary.xml loginsight-config.xml#13

  10. Start the Log Insight service by running this command:

    service loginsight start


Additional Information

Changing internal configuration options in VMware vRealize Log Insight