Falha ao abrir um console de máquina virtual no vSphere Client com o erro: Unable to contact the MKS
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Falha ao abrir um console de máquina virtual no vSphere Client com o erro: Unable to contact the MKS

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VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:

Disclaimer: Este artigo é uma tradução do Opening a virtual machine console from vSphere Client fails with the error: Unable to contact the MKS (2032016). Como os artigos são traduzidos em uma base de melhor esforço, o conteúdo pode tornar-se desatualizado. Para obter o conteúdo mais recente, consulte o artigo em Inglês.


  • Ocorre uma falha inicial ao abrir um console de máquina virtual no vSphere Client com um erro semelhante a:

    Cannot open/create log file 'C:\Users\Administrator\AppData\Local\Temp\1\vmware-Administrator\vmware-xxx-mks-C:\yyyyyyy.log': The filename, directory name, or volume label syntax is incorrect

    Unable to open log file
    "C:\Users\Administrator\AppData\Local\Temp\1\vmware-Administrator\vmware-xxx-mks-C:\yyyyyyy.log". Check your configuration to make sure that the path specified for the log file is valid, and that you have write privileges in this directory.
    Unable to proceed without a log file.

  • Tentativas subsequentes de abrir um console de máquina virtual falham com o erro:

    • vSphere Client 4.x:

      Unable to contact the MKS: Could not connect to pipe\\.\pipe\vmware-authdpipe: The system cannot find the file specified

    • vSphere Client 5.0:

      Unable to connect to the MKS: Host address lookup for server <esxi.domain.com> failed: No such host is known
      The VMRC console has disconnected...attempting to reconnect


  • Após o disparo do evento, o arquivo viclient.log pode exibir entradas semelhantes a:

    [ :QuickInf:M:14] <YYYY-MM-DD>T<time>.945 EmbeddedVMRC::Creating a new console
    [viclient:SoapTran:W:17] <YYYY-MM-DD>T<time>.950 Invoke 141 Finish WaitForUpdates on PropertyCollector:propertyCollector [vc-10-ah] - Serial:0.000, Server:000.110
    [viclient:SoapTran:P:27] <YYYY-MM-DD>T<time>.950 Invoke 143 Finish CreateFilter on PropertyCollector:propertyCollector [vc-10-ah] - Serial:0.000, Server:000.004 [session[5283872a-f284-845b-c12a-9779e19bcc11]52eb3b66-97ef-f02e-ee2b-1f40d3e4b456]
    [viclient:SoapTran:M:14] <YYYY-MM-DD>T<time>.064 Invoke 144 Start GetAlarmActionsEnabled on AlarmManager:AlarmManager [vc-10-ah]. [operationID:5635AC17-00000090][Caller: VpxClient.InventoryContextMenus.SetAlarmContextMenuItems]
    [viclient:SrvMsg :M:14] <YYYY-MM-DD>T<time>.064 RMI Request Vmomi.Alarm.AlarmManager.GetAlarmActionsEnabled - 144
    VirtualMachine:vm-379 [vc-10-ah]
    [viclient:SoapTran:P:27] <YYYY-MM-DD>T<time>.068 Invoke 144 Finish GetAlarmActionsEnabled on AlarmManager:AlarmManager [vc-10-ah] - Serial:0.000, Server:000.004
    [viclient:QuickInf:W:17] <YYYY-MM-DD>T<time>.092 WaitForUpdates Version = 34
    [viclient:SoapTran:W:17] <YYYY-MM-DD>T<time>.092 Invoke 145 Start WaitForUpdates on PropertyCollector:propertyCollector [vc-10-ah]. [operationID:5635AC17-00000091]
    [viclient:SrvMsg :W:17] <YYYY-MM-DD>T<time>.092 RMI Request Vmomi.Core.PropertyCollector.WaitForUpdates - 145
    34
    </time></time></time></time></time></time></time></time></time>

    Observação: para obter mais informações sobre localizações de logs, consulte Collecting diagnostic information for the vSphere Client or VMware Infrastructure Client (1003687).


Environment

VMware ESX 4.0.x
VMware vSphere ESXi 5.0
VMware ESX 4.1.x
VMware ESXi 4.1.x Installable
VMware ESXi 3.5.x Installable
VMware vCenter Server 4.0.x
VMware vCenter Server 5.0.x
VMware ESXi 4.0.x Installable
VMware ESX Server 3.5.x
VMware vCenter Server 4.1.x
VMware vCenter Server 5.1.x

Cause

Esse problema ocorre quando uma variável de ambiente personalizada denominada User é definida na máquina Windows do vSphere Client.

Resolution

Para resolver esse problema, remova a variável de ambiente da máquina do vSphere Client ou do vCenter Server:

  1. Clique em Start > Run, digite sysdm.cpl e pressione Enter. A janela System Properties é aberta.
  2. Clique na guia Advanced.
  3. Clique em Environment Variables.
  4. Remova qualquer variável de usuário e qualquer variável do sistema denominada User.
  5. Reinicialize o Windows e inicie o vSphere Client.
Se o problema persistir, encerre todos os processos vmware-vmrc.exe no Task Manager do Windows:
  1. Feche todas as sessões do vSphere Client.
  2. Abra o Task Manager do Windows.
  3. Procure processos vmware-vmrc.exe e encerre-os.
  4. Inicie o vSphere Client e conecte-se ao host diretamente ou ao vCenter Server.
Observação: se o problema persistir mesmo depois que você tentar as etapas descritos neste artigo, envie uma Solicitação de Suporte ao Suporte da VMware e anote a ID deste artigo da Base de Conhecimento (2032016) na descrição do problema. Para obter mais informações, consulte Filing a Support Request in My VMware (2006985).

Additional Information

Para obter mais informações, consulte Identifying issues with and setting up name resolution on ESX/ESXi Server (1003735). Opening a virtual machine console from vSphere Client fails with the error: Unable to contact the MKS