vSphere Client から仮想マシン コンソールを開くと次のエラーで失敗する:MKS に接続できません
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vSphere Client から仮想マシン コンソールを開くと次のエラーで失敗する:MKS に接続できません

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Article ID: 339717

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VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:

免責事項: これは英文の記事 「Opening a virtual machine console from vSphere Client fails with the error: Unable to contact the MKS (2032016)」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。


  • vSphere Client から仮想マシン コンソールを初めて開くと、次のエラーで失敗する。

    Cannot open/create log file 'C:\Users\Administrator\AppData\Local\Temp\1\vmware-Administrator\vmware-xxx-mks-C:\yyyyyyy.log': The filename, directory name, or volume label syntax is incorrect

    Unable to open log file
    "C:\Users\Administrator\AppData\Local\Temp\1\vmware-Administrator\vmware-xxx-mks-C:\yyyyyyy.log". Check your configuration to make sure that the path specified for the log file is valid, and that you have write privileges in this directory.
    Unable to proceed without a log file.

  • 仮想マシン コンソールを開くための以降の処理が、次のエラーで失敗する。

    • vSphere Client 4.x の場合:

      Unable to contact the MKS: Could not connect to pipe\\.\pipe\vmware-authdpipe: The system cannot find the file specified

    • vSphere Client 5.0 の場合:

      Unable to connect to the MKS: Host address lookup for server <esxi.domain.com> failed: No such host is known
      The VMRC console has disconnected...attempting to reconnect

  • イベントをトリガーすると、viclient.log ファイルに次のようなエントリが記録される。

    [ :QuickInf:M:14] <YYYY-MM-DD>T<time>.945 EmbeddedVMRC::Creating a new console
    [viclient:SoapTran:W:17] <YYYY-MM-DD>T<time>.950 Invoke 141 Finish WaitForUpdates on PropertyCollector:propertyCollector [vc-10-ah] - Serial:0.000, Server:000.110
    [viclient:SoapTran:P:27] <YYYY-MM-DD>T<time>.950 Invoke 143 Finish CreateFilter on PropertyCollector:propertyCollector [vc-10-ah] - Serial:0.000, Server:000.004 [session[5283872a-f284-845b-c12a-9779e19bcc11]52eb3b66-97ef-f02e-ee2b-1f40d3e4b456]
    [viclient:SoapTran:M:14] <YYYY-MM-DD>T<time>.064 Invoke 144 Start GetAlarmActionsEnabled on AlarmManager:AlarmManager [vc-10-ah].[operationID:5635AC17-00000090][Caller:VpxClient.InventoryContextMenus.SetAlarmContextMenuItems]
    [viclient:SrvMsg :M:14] <YYYY-MM-DD>T<time>.064 RMI Request Vmomi.Alarm.AlarmManager.GetAlarmActionsEnabled - 144
    VirtualMachine:vm-379 [vc-10-ah]
    [viclient:SoapTran:P:27] <YYYY-MM-DD>T<time>.068 Invoke 144 Finish GetAlarmActionsEnabled on AlarmManager:AlarmManager [vc-10-ah] - Serial:0.000, Server:000.004
    [viclient:QuickInf:W:17] <YYYY-MM-DD>T<time>.092 WaitForUpdates Version = 34
    [viclient:SoapTran:W:17] <YYYY-MM-DD>T<time>.092 Invoke 145 Start WaitForUpdates on PropertyCollector:propertyCollector [vc-10-ah].[operationID:5635AC17-00000091]
    [viclient:SrvMsg :W:17] <YYYY-MM-DD>T<time>.092 RMI Request Vmomi.Core.PropertyCollector.WaitForUpdates - 145
    34
    </time></time></time></time></time></time></time></time></time>

    :前述のログの引用は単なる例です。日付、時間、および環境変数は、環境によって異なる場合があります。

    :ログの場所については、「vSphere Client または VMware Infrastructure Client の診断情報の収集 (2080977)」を参照してください。


Environment

VMware vSphere ESXi 5.0
VMware ESX 4.1.x
VMware ESXi 4.0.x Installable
VMware ESX Server 3.5.x
VMware vCenter Server 5.0.x
VMware vCenter Server 4.0.x
VMware ESXi 4.1.x Installable
VMware ESXi 3.5.x Installable
VMware vCenter Server 5.1.x
VMware vCenter Server 4.1.x
VMware ESX 4.0.x

Cause

この問題は、User という名前のカスタム環境変数が vSphere Client マシン上の Windows で設定されている場合に発生します。

Resolution

この問題を解決するには、環境変数を vSphere Client マシンまたは vCenter Server から削除します:

  1. [スタート] > [ファイル名を指定して実行] をクリックし、sysdm.cpl と入力して Enter を押します。[システムのプロパティ] ウィンドウが開きます。
  2. [詳細] タブをクリックします。
  3. [環境変数] をクリックします。
  4. User という名前のユーザー変数とシステム変数を削除します。
  5. Windows を再起動し、vSphere Client を起動します。
問題が解決しない場合は、Windows タスク マネージャで vmware-vmrc.exe プロセスをすべて終了します:
  1. すべての vSphere Client セッションを閉じます。
  2. Windows タスク マネージャを開きます。
  3. vmware-vmrc.exe プロセスをすべて検索し、プロセスを終了します。
  4. vSphere Client を起動し、直接ホストに、または vCenter Server に接続します。
:この記事の手順を実行しても問題が解決されない場合は、VMware サポートにサポート リクエストを提出し、このナレッジ ベースの記事 ID (2032016) を問題の説明の中に記入してください。詳細については、「My VMware でサポート リクエストを提出する方法 (2079666)」を参照してください。

Additional Information

詳細については、「ESX/ESXi Server における名前解決の問題の特定とセットアップ (1033033)」を参照してください。Opening a virtual machine console from vSphere Client fails with the error: Unable to contact the MKS