Resetting the niscache and deviceid of a robot or hub in DX UIM
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Resetting the niscache and deviceid of a robot or hub in DX UIM

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Article ID: 33954

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM)

Issue/Introduction

  • How do I reset the niscache and the device id of a robot or hub or when I clone a robot?
  • Sometimes resetting niscache and device id can resolve issues with discovery such as "robots not present in CM_NIMBUS_ROBOT". Procedure to run niscache clean. 

Environment

  • DX UIM 23.4.*
  • any robot version

Cause

  • When you clone a robot it can duplicate the robot device id causing the data for both robots to merge into a single robot.
  • niscache / robot deviceid mismatch can create inconsistencies with discovery correlation

Resolution

In case of cloning, as a previous step, ensure robot/system IP/hostname consistency: 

  • Correct the hostname and IP in the robot.cfg by using the controller probe, configure probe, to set the new hostname and the new ip.
  • Restart the robot. Right click on each probe that is not getting a port and select validate->security->okay

 

Reset niscache and reser robot device_id steps: 

  • Infrastructure Manager (IM): 

    1. Navigate to the robot which needs to have its device id or niscache reset

    2. Highlight the 'controller' probe and press 'CTRL + P'
    3. When the probe utility for the controller probe comes up, select 'Options' (the icon with the gear)

    4. Put a check in 'Expert Mode' and click OK
                  



    5. Pulldown on the 'Probe commandset' menu and select '_nis_cache_clean' then press play,
    6. then select '_reset_device_id_and_restart' This will flush the niscache folder, including the robot device id.



      The robot will restart and immediately begin to repopulate the niscache (beginning with the robot device id).

    7. Repeat this procedure on all robots which were cloned.


  • Use Admin Console (AC)
     
    1. Access probe utility from the 3 dots to the left of the probe name.




    2. Find the options at the bottom of the list on the left. (There is no options or expert mode from Admin Console)

 

 

 

 

 

NOTE: 

For cloned robots, it might be necessary to Delete the device and have the discovery server to "rediscover it" cleanly. For deleting device: 

  1. Go to Operator Console and Inventory,
  2. Find these robots using the search from the Add Filter box.
  3. Put a check in the box next to the robot, from the three dots on the top right pull down select "Delete Selected".

        

  4.  REMOVE the check from prevent rediscovery and press Delete.



    This will clean up the entries in Operator Console.