CA UIM resetting the niscache and deviceid of a robot or hub or a robot that was cloned.
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CA UIM resetting the niscache and deviceid of a robot or hub or a robot that was cloned.

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Article ID: 33954

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM)

Issue/Introduction

How do I reset the niscache and the device id of a robot or hub or when I clone a robot?

 

Environment

Release:
Component: CAUIM 20.4 and above

Cause

When you clone a robot it can duplicate the robot device id causing the data for both robots to merge into a single robot.

Resolution

Change the hostname and IP of the server
Correct the hostname and IP in the robot.cfg by using the controller probe, configure probe, to set the new hostname and the new ip.
Restart the robot. Right click on each probe that is not getting a port and select validate->security->okay

Use the process when directed by support to clear the niscache or robotid or if you clone robots and hubs.
Use the probe utility to reset both items.

 when using IM, use the following procedure:

1) Navigate to the robot which needs to have its device id or niscache reset

2) Highlight the 'controller' probe and press 'CTRL + P'

3) When the probe utility for the controller probe comes up, select 'Options' (the icon with the gear)

4) Put a check in 'Expert Mode' and click OK



5) Pulldown on the 'Probe commandset' menu and select '_nis_cache_clean' then press play, then select '_reset_device_id_and_restart' This will flush the niscache folder, including the robot device id. Then the robot will restart and immediately begin to repopulate the niscache (beginning with the robot device id). Repeat this procedure on all robots which were cloned.

When using Administrator console, you can access probe utility from the 3 dots to the left of the probe name.

You will find the options you need at the bottom of the list on the left. There is no options or expert mode from Admin Console

6) Go to Operator Console and Inventory, find these robots using the search from the Add Filter box. Put a check in the box next to the robot, from the three dots on the top right pull down select "Delete Selected".

7)  REMOVE the check from prevent rediscovery and press Delete. This will clean up the entries in Operator Console.