Cloud Foundation Stretched Cluster Workflow Error "Current applied vSAN license doesnt support the required cpu count {0}"
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Article ID: 339530
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Updated On:
Products
VMware Cloud Foundation
Issue/Introduction
Symptoms: When triggering the Stretched Cluster Workflow in Cloud Foundation the task manager reports the following error: "Current applied vSAN license doesn't support the required CPU count {0}"
Environment
VMware Cloud Foundation 3.7.x VMware Cloud Foundation 3.5.x
Cause
The cause of the problem is related to a validation task in the Stretched Cluster workflow that determines the number of cores each of the stretched cluster hosts currently has and then compares the count to the number of vSAN Licenses that are available. vSAN uses socket-based licensing which leads to a discrepancy between the core determined in the workflow versus the socket count on the specified license.