VDP 6.1.6 or later ISO not detected during upgrade
search cancel

VDP 6.1.6 or later ISO not detected during upgrade

book

Article ID: 339450

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

To resolve VDP ISO detection issues


Symptoms:
  • When attempting to upgrade VDP appliance from 6.1.x to 6.1.6 or later, ISO does not get detected.
  • Upgrade tab in VDP-Configure page, reports below message:
"To upgrade your VDP appliance, please connect a valid upgrade ISO image to the appliance." 
  • The command line, the ISO shows already mounted:
root@Jimbo:~/#: df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda2        32G  5.9G   25G  20% /
udev            1.9G  148K  1.9G   1% /dev
tmpfs           1.9G     0  1.9G   0% /dev/shm
/dev/sda1       128M   37M   85M  31% /boot
/dev/sda7       1.5G  158M  1.3G  12% /var
/dev/sda9       138G  5.1G  126G   4% /space
/dev/sdd1       256G  208M  256G   1% /data02
/dev/sdc1       256G  208M  256G   1% /data03
/dev/sdb1       256G  4.3G  252G   2% /data01
/dev/sr0        4.1G  4.1G     0 100% /mnt/auto/cdrom
  • If the ISO is not mounted, then use the below command to mount:
# mount /dev/sr0 /mnt/auto/cdrom
  • Modified date for /usr/local/avamar/var/avi/server_log/avinstaller.log is very old:
-rw-r--r-- 1 root  root  1686327 Nov 11 2017 21:12 avinstaller.log
  • Restarting avinstaller service does not update the log file:
#avinstaller.pl --restart


Environment

VMware vSphere Data Protection 6.1.x

Resolution

  • To resolve this issue, rename the web server folder "jetty-0.0.0.0-7543-avi.war-_avi-any-" located under /usr/local/avamar/lib/jetty/work:
# cd /usr/local/avamar/lib/jetty/work
  • Use the mv command:
# mv jetty-0.0.0.0-7543-avi.war-_avi-any- jetty-0.0.0.0-7543-avi.war-_avi-any-old
  • Then restart the avinstaller script using #avinstaller.pl --restart
  • Validate if the avinstaller.log is updated:
-rw-r--r-- 1 root  root  1750549 Aug 09 19:38 avinstaller.log.0
  • ISO should now be detected in the vdp-configure page.
  • If this does not help, review the log : /usr/local/avamar/var/avi/server_log/avinstaller.log for errors and open a ticket with VMware.