VMware vCenter Site Recovery Manager fails to create a pair connection with the error: Wrong server type found on target 'x.x.x.x'
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VMware vCenter Site Recovery Manager fails to create a pair connection with the error: Wrong server type found on target 'x.x.x.x'

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Article ID: 339368

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:
  • Cannot create a pair connection in vCenter Site Recovery Manager (SRM) between the protected site and the recovery site.
  • You see the error:

    SRM Server "Site Recovery for x.x.x.x" cannot do a pair connection. The reason is "wrong server type found on target 'x.x.x.x'


  • In the vmware-dr.log file, you see entries similar to:

    YYYY-MM-DDT14:33:26.798-05:00 [02860 error 'DrRemoteSiteManager'] Wrong server type at 192.168.110.212:80//sdkTunnel. Found Unknown, required VC.
    YYYY-MM-DDT14:34:46.828-05:00 [01100 error 'DrRemoteSiteManager'] Wrong server type at 192.168.110.212:80//sdkTunnel. Found Unknown, required VC.
    YYYY-MM-DDT08:22:04.411-05:00 [01948 error 'DrRemoteSiteManager'] Wrong server type at 192.168.110.212:80//sdkTunnel. Found Unknown, required VC.


    Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

    Note: The location of the vmware-dr.log file is:

    SRM 4.x and 5.x:
    • Windows XP and 2003: %ALLUSERSPROFILE%\Application Data\VMware\VMware vCenter Site Recovery Manager\Logs\
    • Windows 2008: \ProgramData\VMware\VMware vCenter Site Recovery Manager\Logs\
    • Windows Vista, 7: %ALLUSERSPROFILE%\VMware\VMware vCenter Site Recovery Manager\Logs\

    SRM 1.0:
  • Windows 2000, XP and 2003: %ALLUSERSPROFILE%\Application Data\VMware\VMware Site Recovery Manager\Logs\


Environment

VMware vCenter Site Recovery Manager 4.0.x
VMware vCenter Site Recovery Manager 1.0.x
VMware vCenter Site Recovery Manager 5.5.x
VMware vCenter Site Recovery Manager 5.1.x
VMware vCenter Site Recovery Manager 5.0.x
VMware vCenter Site Recovery Manager 4.1.x
VMware vCenter Site Recovery Manager 5.8.x

Cause

This issue occurs when a network security appliance or a firewall rule is blocking ingress traffic on port 80 TCP/UDP while a HTTP rule is set to allow ingress traffic. This issue can also appear when the SRM version running on a PR and SR sites do not match.

Resolution

To troubleshoot this issue, perform these steps:

  1. Verify that the PR and SR sites are running the same version of SRM. Upgrade the site running the earlier version, or downgrade the site running the later version as necessary. If this change resolves the issue, further troubleshooting steps can be skipped.

  2. Verify that the intermediate and front end network security appliances (sometimes referred to as Web Filters) do not block or slow down the ingress and egress traffic using port 80 TCP/UDP.

    Note: If you have issues with this procedure, contact your network security appliance vendor.

  3. Create a white list by IP address to allow ingress and egress traffic on port 80 TCP/UDP and disable DPI (Deep Packet Inspection).

    Note: For information on disabling DPI, contact your network security appliance vendor.


  4. Remove the HTTP rule as it stops inspection of traffic on port 80.


Additional Information

For related information, see:

Testing port connectivity with Telnet
Ports that must be open for Site Recovery Manager 1.0.x to 5.5.x, vSphere Replication 1.0.x to 5.5.x, and vCenter Server
Firewall blocks traffic for network-backed virtual serial ports