SDDC Manager password operations are not allowed because of a failed password task
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SDDC Manager password operations are not allowed because of a failed password task

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Article ID: 339041

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Updated On: 03-31-2025

Products

VMware Cloud Foundation

Issue/Introduction

When attempting to perform any password task one of these errors is seen

"This operation is not allowed because Password Manager operation(s) are working on related resources" 

"The scheduled auto-rotate workflow could not run due to another operation blocking the resources" banner on VCF UI

"THE OPERATION IS NOT ALLOWED BECAUSE THE SYSTEM LOCK IS HELD BY PASSWORD MANAGER OPERATION IN PROGRESS" 

Similar errors are seen in the operationsmanager.log

/var/log/vmware/vcf/operationsmanager.log

yyyy-mm-ddThh:mm:ss DEBUG [vcf_om,404f8e66713d47ef,f8fb] [c.v.e.s.e.h.LocalizableRuntimeExceptionHandler,http-nio-127.0.0.1-7300-exec-4] Handler Error Response: {"errorCode":"PASSWORD_MANAGER_UPDATE_IN_PROGRESS","arguments":["d68f530d-1cd7-4988-af5b-28f8dda87699"],"message":"Password update task d68f530d-1cd7-4988-af5b-28f8dda87699 is in progress/failed state, retry after sometime.","remediationMessage":"Wait for currently in-progress transaction to complete as succeeded/cancelled.","referenceToken":"GURKAF"}
 

Environment

VMware Cloud Foundation 4.x
VMware Cloud Foundation 5.x

Cause

  • There might be a password rotation task failed on individual components due to other reasons(Password expired, SSH disabled etc)
  • Reported failed workflow of password manager holds a lock due to task being in FAILED or IN_PROGRESS state 
Note: The task should either be in USER_CANCELLED or SUCCESSFUL state


Resolution

Note: If you see a banner on the Password Manager page, Cancel the task from the UI. If the issue is still not resolved, please contact Broadcom support.

Additional Information