HTTP Error 400 in vSphere Client: No matching request found for WebSSO response.
search cancel

HTTP Error 400 in vSphere Client: No matching request found for WebSSO response.

book

Article ID: 338897

calendar_today

Updated On: 04-29-2025

Products

VMware vCenter Server

Issue/Introduction

  • Unable to login if you enter your credentials again on a session that you left open and vCenter Server logged out of your account due to the timeout settings for the vSphere Client.
  • Unable to login if you enter your credentials on a login screen open for some time and unattended.

Either of the two actions above will display the following error after entering the credentials to access vCenter Server through the vSphere Client:

Environment

VMware vCenter Server 7.0.x
VMware vCenter Server 8.0.x

Cause

This occurs if a user keeps the UI login screen (the same happens with the timeout banner) and stays there without performing an actual login.

This is a security protection feature to make sure that login request originates from this browser.

Resolution

This is an expected behavior. Hitting in the bottom "Back to login screen" or refreshing the web browser before login is the correct process to log back into the vSphere Client. 
This couldn't be disabled as this is a security method that VMware implemented in 7.0 and above.

Workaround : 
The timeout can be increased by following these steps:

    1. Backup the configuration file of the vSphere Client:
      cp /etc/vmware/vsphere-ui/webclient.propertie /etc/vmware/vsphere-ui/webclient.propertie.bk
    2. Open the configuration file of the vSphere Client:
      vi /etc/vmware/vsphere-ui/webclient.properties
      and add the variable websso.request.timeout=XX ( where XX must be a positive integer number specified in minutes)
      e.g. websso.request.timeout=120

    3. Restart the UI service: 
      service-control --stop vsphere-ui && service-control --start vsphere-ui