HTTP Error 400 in vSphere Client: No matching request found for WebSSO response
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Article ID: 338897
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Updated On:
Products
VMware vCenter Server
Issue/Introduction
Symptoms:
Unable to login if you enter your credentials again on a session that you left open and VC logged out of your account due to the timeout settings for the vSphere Client.
Unable to login if you enter your credentials on a login screen open for some time and unattended.
Either of the two actions above will display the following error after entering the credentials to access vCenter Server through the vSphere Client:
Environment
VMware vCenter Server 7.0.x VMware vCenter Server 8.0.x
Cause
This occurs if a user keeps the UI login screen (the same happens with the timeout banner) and stays there without performing an actual login.
This is a security protection feature to make sure that login request originates from this browser.
Resolution
This is an expected behavior. Hitting in the bottom "Back to login screen" or refreshing the web browser before login is the correct process to log back into the vSphere Client.
This couldn't be disabled as this is a security method that VMware implemented in 7.0+.