Services tab in VAMI shows warning message vCenter Server health is GREEN vc.health.error.dbjob2
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Services tab in VAMI shows warning message vCenter Server health is GREEN vc.health.error.dbjob2

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Article ID: 338896

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

vSphere VAMI page shows a warning message vCenter Server health is GREEN vc.health.error.dbjob2

In the /var/log/vmware/vsphere-ui/logs/vsphere_client_virgo.log you see errors similar to:


[2023-08-15T19:01:06.981Z] [INFO ] MessageBroker-1               o.springframework.web.socket.config.WebSocketMessageBrokerStats   WebSocketSession[0
current WS(0)-HttpStream(0)-HttpPoll(0), 0 total, 0 closed abnormally (0 connect failure, 0 send limit, 0 transport error)], stompSubProtocol[processed CONNECT(0)-CONNECTED(0)-DISCONNECT(0)], stompBrokerRelay[null], inboundChannel[pool size = 0, active threads = 0, queued tasks = 0, completed tasks
= 0], outboundChannel[pool size = 0, active threads = 0, queued tasks = 0, completed tasks = 0], sockJsScheduler[pool size = 1, active threads = 1, queued tasks = 0, completed tasks = 0]
[2023-08-15T19:01:07.229Z] [INFO ] agw-token-acq1               ######## ###### 200004 com.vmware.vim.sso.client.impl.SiteAffinityServiceDiscovery   Site affinity is disabled


There is "vc.health.error.dbjob2" in VAMI.
If you grep locmsg.vmsg for  "vc.health.error.dbjob2" you will find the following message:

# grep vc.health.error.dbjob2 /etc/vmware-vpx/locale/en/locmsg.vmsg
vc.health.error.dbjob2 = "Performance statistics rollup from Past Week to Past Month is not occurring in the database"

Environment

VMware vCenter Server 8.0.x
VMware vCenter Server 7.0.x

Cause

The issue is mainly caused by the Performance statistics rollup from Past Week to Past Month is not occurring in the database.

Resolution

  1. Take a snapshot of the VCSA and if the customer agrees, delete old tasks, events and statistics data in the vCenter Server database.
  2. Follow KB  Delete old tasks, events and statistics data in vCenter Server 5.x, 6.x, 7.x and 8.x and use the script to set the retention history to what the customer prefers.
  3. SSH into the VCSA with the root user and restart VCSA services with the following command or reboot vCenter

service-control --stop --all && service-control --start --all