"Failed to register Auto Deploy" error while Upgrading Windows vCenter Server 6.5 to 6.7
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"Failed to register Auto Deploy" error while Upgrading Windows vCenter Server 6.5 to 6.7

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Article ID: 338836

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
When attempting to upgrade a Windows vCenter Server to 6.7 GA, you experience these symptoms:
  • Error while configuring vSphere Auto Deploy Waiter firstboot:
"Failed to register Auto Deploy"
  • Installation of component VCSServiceManager failed with error code '1603'. Check the logs for more details.
  • In log bundle collected on the desktop VMware-VCS-logs-xxxxx/vcs_logs/uninstall/vc-vchostname/ProgramData/VMware/vCenterServer/logs/firstboot/fbInstall.json file, you see entries similar to:
{    "error": {       "detail": [
            {
                "id": "install.autodeploy.action.failed",
                "args": [
                    "firstboot"
                ],
                "localized": "Error while configuring vSphere Auto Deploy Waiter firstboot.",
                "translatable": "Error while configuring vSphere Auto Deploy Waiter %(0)s."
            },
            {
                "id": "install.autodeploy.register.failed",
                "localized": "Failed to register Auto Deploy",
                "translatable": "Failed to register Auto Deploy"
            }
        ],
        "componentKey": "rbd",
        "resolution": {
            "id": "install.autodeploy.action.failed.resolution",
            "localized": "Search for these symptoms in the VMware knowledge base for any known issues and possible workarounds. If none can be found, collect a support bundle and open a support request.",
            "translatable": "Search for these symptoms in the VMware knowledge base for any known issues and possible workarounds. If none can be found, collect a support bundle and open a support request."
        },
        "problemId": "install.autodeploy.action.failed"
    },
    "progress_message": {
        "id": "install.ciscommon.component.starting",
        "args": [
            "VMware vSphere Auto Deploy Waiter"
        ],
        "localized": "Starting VMware vSphere Auto Deploy Waiter...",
        "translatable": "Starting %(0)s..."
    },
    "end_time": "2018-04-23T01:10:43.875Z",
    "start_time": "2018-04-23T01:00:08.327Z",
    "warning": [],
    "question": null,
    "status": "error",
    "info": [],
    "progress": 90
}
  • In support bundle VMware-VCS-logs-xxxxx/vcs_logs/uninstall/autodeploy-firstboot.py_9568_stderr.log file, you see entries similar to:
<YYYY-MM-DD><time> Invoked command: ['netsh', 'advfirewall', 'firewall', 'delete', 'rule', 'protocol=TCP', 'name=VMware vCenter Server - autodeploy']
<YYYY-MM-DD><time> RC = 1
Stdout =
No rules match the specified criteria.

Stderr =
<YYYY-MM-DD><time> Unable to delete the Auto Deploy firewall rule
Traceback (most recent call last):
  File "C:\Program Files\VMware\vCenter Server\firstboot\autodeploy-firstboot.py", line 849, in _closeWinPort
    invoke_command(command)
  File "C:\Program Files\VMware\vCenter Server\python-modules\cis\utils.py", line 369, in invoke_command
    (cmd, stderr))
cis.exceptions.InvokeCommandException: {
    "resolution": null,
    "problemId": null,
    "componentKey": null,
    "detail": [
        {
            "args": [
                "Command: ['netsh', 'advfirewall', 'firewall', 'delete', 'rule', 'protocol=TCP', 'name=VMware vCenter Server - autodeploy']\nStderr: "
            ],
            "id": "install.ciscommon.command.errinvoke",
            "translatable": "An error occurred while invoking external command : '%(0)s'",
            "localized": "An error occurred while invoking external command : 'Command: ['netsh', 'advfirewall', 'firewall', 'delete', 'rule', 'protocol=TCP', 'name=VMware vCenter Server - autodeploy']\nStderr: '"
        }
    ]
}

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.


Environment

VMware vCenter Server 6.5.x
VMware vCenter Server 6.7.x

Cause

This issue occurs due to conflicting openssl libraries installed in the vCenter Server operating system.

Resolution

This issue was resolved in vCenter Server 6.7.0a, build 8546234.  For more information see: Full Patch for VMware vCenter Server Appliance 6.7.0a.

Workaround:

To workaround this issue, follow the steps below.

  1. Go to Start > Run > sysdm.cpl > Advanced tab > Environment Variable.
  2. Click Edit and locate the C:\Program Files\VMware\vCenter Server\openSSL and move it to the top.
For example:

Change this Path=C:\Program Files\EMC NetWorker\nsr\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Microsoft SQL Server\110\Tools\Binn\;C:\Program Files\Microsoft SQL Server\110\Tools\Binn\;C:\Program Files\Microsoft SQL Server\110\DTS\Binn\;C:\Program Files\MIT\Kerberos\bin;C:\Program Files\VMware\vCenter Server\openSSL

To

C:\Program Files\VMware\vCenter Server\openSSL;Path=C:\Program Files\EMC NetWorker\nsr\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Microsoft SQL Server\110\Tools\Binn\;C:\Program Files\Microsoft SQL Server\110\Tools\Binn\;C:\Program Files\Microsoft SQL Server\110\DTS\Binn\;C:\Program Files\MIT\Kerberos\bin;

  1. Re-try the vCenter Server upgrade.