Editing vCenter Single Sign-On password policies fails with the error: The error has no message
search cancel

Editing vCenter Single Sign-On password policies fails with the error: The error has no message

book

Article ID: 338795

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
  • Cannot edit the vCenter Single Sign-On (SSO) password policies
  • Editing the vCenter Single Sign-On (SSO) password policies fails
  • When you edit the vCenter Single Sign-On (SSO) password policies, you see the error:

    The last operation failed for the entity with the following error message

    The error has no message


Environment

VMware vCenter Server 5.5.x
VMware vCenter Server 5.1.x

Cause

This issue occurs if there is no value set in the Maximum Lifetime field when editing password policies. The value is set to NaN.

Resolution

This issue is resolved in vCenter Server 6.0.x and 6.5 available at VMware Downloads.

To work around this issue in previous versions, change the Maximum Lifetime value from NaN to zero for vSphere 5.1 or to 9999 for vSphere 5.5.

To change the Maximum Lifetime value:
  1. Log in to the vSphere Web Client as the SSO Administrator:

  2. Click Administration.
  3. Click Configuration under Single Sign-On:
  4. Click Policies > Edit.
  5. Change the Maximum Lifetime value from NaN to:
    • For vSphere 5.1, use: 0
    • For vSphere 5.5, use: 9999

      Notes:
      • In vSphere 5.5, using 0 as a Maximum Lifetime value causes the edit to fail.
      • The description field cannot be blank.
  6. Click OK.


Additional Information

To be alerted when this document is updated, click the Subscribe to Article link in the Actions box.
vCenter Single Sign-On パスワード ポリシーの編集が次のエラーで失敗する:エラーにメッセージがありません (The error has no message)
编辑 vCenter Single Sign-On 密码策略失败并显示以下错误:无任何有关此错误的消息 (The error has no message)