"Server returned 'request expired' less than 0 seconds after request was issued" error when Registering vSphere replication
search cancel

"Server returned 'request expired' less than 0 seconds after request was issued" error when Registering vSphere replication

book

Article ID: 338568

calendar_today

Updated On:

Products

VMware Live Recovery VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • Registering vSphere Replication to PSC fails.
  • You see this error:

    Server returned 'request expired' less than 0 seconds after request was issued, but it shouldn't have expired for at least 600 seconds.

  • In the /opt/vmware/hms/logs/hms.log file, you see time skew entries similar to:

    2017-01-14 06:57:00.694 ERROR com.vmware.vim.sso.client.impl.SoapBindingImpl [main] (..client.impl.SoapBindingImpl) | SOAP fault
    javax.xml.ws.soap.SOAPFaultException: The time now Wed Jan 18 12:27:31 MST 2017 does not fall in the request lifetime interval extended with clock tolerance of 600000 ms: [ Sat Jan 14 06:47:00 MST 2017; Sat Jan 14 07:17:00 MST 2017). This might be due to a clock skew problem.


    Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.
 
 


Environment

VMware vSphere Replication 8.x

Cause

This issue occurs due to a time skew between vCenter Server and the vSphere Replication Appliance

Resolution

To resolve this issue, configure an NTP server.
 
 
To work around this issue, manually synchronize the time to match vCenter Server/PSC:
  1. Open console of vSphere replication appliance and log in using root credentials.
  2. Enable SSH. For more information, see Activate or Deactivate SSH Access to the vSphere Replication Appliance (vmware.com)
  3. Run this command to update the time:

    date --set="DD MONTH YYYY HH:MM:SS"

    For example:

    date --set="24 May 2015 16:25:00"