Registering VR 8.1 appliance gives "Bad exit code 1" after upgrading from 6.5 to 8.1
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Article ID: 338460
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Updated On:
Products
VMware Live Recovery
VMware vSphere ESXi
Issue/Introduction
Symptoms:
Registering VR 8.1 appliance gives "Bad exit code 1" after upgrading from 6.5 to 8.1
Environment
VMware vSphere Replication 8.x
Cause
This issue is caused:
1. Stale vSphere Replication solution users
2. PSC replication errors
Resolution
To workaround this issue:
Before registering the VRMS 8.1 to the PSC
- Remove VR solution users
- Log into the Flex client.
- Select Administrator > User and Groups > Solution users
- Select vSphere Replication Solution user(s) and click delete.
- Unregister stale VR solution users from PSC
- Login to PSC through SSH.
- List the current services registered to the Platform Services Controller.
usr/lib/vmidentity/tools/scripts/lstool.py list --url https://localhost/lookupservice/sdk --no-check-cert 2>/dev/null > /tmp/services.txt
- Open the generated text file to find a list of services registered to the Platform Services Controller and check for vSphere replication.
- To unregister the VR service endpoint, run this command:
/usr/lib/vmidentity/tools/scripts/lstool.py unregister --url http://localhost:7080/lookupservice/sdk --id Service_ID from Step 5 --user'[email protected]' --password 'administrator_password' --no-check-cert
- To Check if ovfEnv.xml is populated.
- Login to vSphere Replication Appliance through SSH/Console.
- Check the ovfEnv.xml file located at /opt/vmware/etc/vami, see KB 2106709
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