Registering VR 8.1 appliance gives "Bad exit code 1" after upgrading from 6.5 to 8.1
search cancel

Registering VR 8.1 appliance gives "Bad exit code 1" after upgrading from 6.5 to 8.1

book

Article ID: 338460

calendar_today

Updated On:

Products

VMware Live Recovery VMware vSphere ESXi

Issue/Introduction

Symptoms:
Registering VR 8.1 appliance gives "Bad exit code 1" after upgrading from 6.5 to 8.1



Environment

VMware vSphere Replication 8.x

Cause

This issue is caused: 

1. Stale vSphere Replication solution users
2. PSC replication errors 

Resolution

To workaround this issue:

Before registering the VRMS 8.1 to the PSC 
  1. Remove VR solution users
    1. Log into the Flex client.
    2. Select Administrator > User and Groups > Solution users
    3. Select vSphere Replication Solution user(s) and click delete.
  2. Unregister stale VR solution users from PSC
    1. Login to PSC through SSH.
    2. List the current services registered to the Platform Services Controller.
 
usr/lib/vmidentity/tools/scripts/lstool.py list --url https://localhost/lookupservice/sdk --no-check-cert 2>/dev/null > /tmp/services.txt
  1. Open the generated text file to find a list of services registered to the Platform Services Controller and check for vSphere replication.
  1. To unregister the VR service endpoint, run this command:
/usr/lib/vmidentity/tools/scripts/lstool.py unregister --url http://localhost:7080/lookupservice/sdk --id Service_ID from Step 5 --user'[email protected]' --password 'administrator_password' --no-check-cert
  1. To Check if ovfEnv.xml is populated.
    1. Login to vSphere Replication Appliance through SSH/Console.
    2. Check the ovfEnv.xml file located at /opt/vmware/etc/vami, see KB 2106709