Unable to see some information from Smarts Solution pack in Front End (FE); Error: CAS Session Expired, need to renew proxy ticket
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Unable to see some information from Smarts Solution pack in Front End (FE); Error: CAS Session Expired, need to renew proxy ticket

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Article ID: 338344

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

User getting the following error in EMC M&R when looking at certain reports from the EMC Smarts Solution pack:

"CAS Session Expired, need to renew proxy ticket"


Unable to access some information collected by the Smarts Solution pack in EMC M&R.

One or both of these symptoms are present:

  • Error in mashupengine.log:
CAS Session Expired, need to renew proxy ticket
  • Error in catalina log:
There is no Action mapped for namespace [/] and action name [cas/realm-login] associated with context path



Environment

MnR 7.X

Smarts 10.1.X

Cause

CAS session has expired due to changes to the EDAA configuration

Resolution

If both symptoms are present:

  • Check runcmd_env.sh for SM_CAS_SERVER
  • Restart services on the Smarts SAM server, including the EDAA services

Perform only step 2 if runcmd_env.sh parameters are correct.

SM_CAS_SERVER in runcmd_env.sh

Format should be http://<M&RHostName>:58080. If any additional texts are added after the port, this will cause a redirect issue with CAS login.

e.g. Error in catalina shows:
There is no Action mapped for namespace [/] and action name [cas/realm-login] associated with context path [/APG]. - [unknown location]
This means that SM_CAS_SERVER has additional /APG text after port 58080.
 
Restart services on the Smarts SAM server
Stop all services:
./sm_service stop --all

To check that all services are stopped use: 

./sm_service show

Then start all services:

./sm_service start --all
  • Notes: Commands will restart all services, you'll only need to restart EDAA.