vRealize Orchestrator search displays "search error:null" when searching for longer strings
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vRealize Orchestrator search displays "search error:null" when searching for longer strings

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Article ID: 338300

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
When using the search function in the vRealize Orchestrator client, you see "search error: null" displayed.

Environment

VMware vRealize Orchestrator 7.3.x

Cause

This can occur when there are duplicated scripting modules stored in the vRealize Orchestrator database.

Resolution

Prerequisites

Create a connection for the vRealize Orchestrator SQL plugin to the vRealize Orchestrator database. This connection will be used as an input for the workflow we will run.

Procedure

  1. Download action_db_records_fix.package.gz attached to this article.
  2. Unzip the workflow package and import into vRealize Orchestrator using the client.
  3. Run 'Repair Corrupted Script Content' workflow
  4. Select the vRealize Orchestrator database from the SQL plugin as the input for the workflow and click submit
    • This workflow looks for and deletes duplicate records for scripting modules. If there is any question as to which of the duplicates should be deleted, the user is prompted for input. No configuration elements will be altered.
  5. Test the search functionality in the vRealize Orchestrator client.


Attachments

action_db_records_fix.package get_app