"ERROR: failed to create initial dc reg value" error while deploying/upgrading to VCSA 6.7
search cancel

"ERROR: failed to create initial dc reg value" error while deploying/upgrading to VCSA 6.7

book

Article ID: 338254

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:

firstbootStatus.json contains the following:
 
"failedSteps": "vmafd-firstboot"

vmafd_firstboot.py_#####_stderr.log contains the following:
2018-04-25T14:24:50.397Z  Exception: Traceback (most recent call last):
  File "/usr/lib/vmware-vmafd/firstboot/vmafd-firstboot.py", line 189, in main
    wait_for_dc_reg_val_update()
  File "/usr/lib/vmware-vmafd/firstboot/vmafd-firstboot.py", line 126, in wait_for_dc_reg_val_update
    problemId = "install.vmafd.wait_for_dc_reg_val_update_failed")
cis.baseCISException.BaseInstallException: {
    "problemId": "install.vmafd.wait_for_dc_reg_val_update_failed",
    "componentKey": "vmafd",
    "resolution": {
        "translatable": "Please search of these symptoms in the VMware Knowledge Base for any known issues and possible workarounds. If none can be found, please collect a support bundle and open a support request.",
        "id": "install.vmafd.wait_for_dc_reg_val_update_failed.resolution",
        "localized": "Please search of these symptoms in the VMware Knowledge Base for any known issues and possible workarounds. If none can be found, please collect a support bundle and open a support request."
    },
    "detail": [
        {
            "translatable": "ERROR: failed to create initial dc reg value",
            "id": "install.vmafd.wait_for_dc_reg_val_update_failed",
            "localized": "ERROR: failed to create initial dc reg value"
        }
    ]
}

 

cloudvm.log contains the following: 

Stdout: DNS reverse lookup on [IP_Address] has failed.
Unable to obtain hostname from DNS reverse lookup.
Please examine DNS/network configuration.

Note: 
  • vCenter Server Appliance - Firstboot logs are located in the /var/log/firstboot directory.

/var/log/vmware/applmgmt/vami.log

"status": "error",
"warning": [],
"question": null,
"progress_message": {
"id": "install.ciscommon.component.starting",
"args": [
   "VMware Authentication Framework"    
    "translatable": "The installation of vCenter Server failed due to an internal error."
"componentKey": "fb-infra",
"problemId": null,
"resolution": {
"id": "install.default.failure.resolution",
    "translatable": "This is an unrecoverable error, please retry install. If you encounter this error again, please search for these symptoms in the VMware Knowledge Base for any known issues and possible resolutions. If none can be found, collect a support bundle and open a support request."


Environment

VMware vCenter Server Appliance 6.7.x

Cause

This issue occurs when deploying a vCenter Server Appliance 6.7 with an IP address that has no DNS record configured.  IP based deployments without DNS are not supported.

Resolution

Before deploying a vCenter Server Appliance 6.7 with a static IP address, verify that the IP address has a valid (internal) domain name system (DNS) registration.  

For more information about DNS requirements see: DNS Requirements for the vCenter Server Appliance and Platform Services Controller Appliance.