vCenter Server Appliance 6.7 Migration Fails During Firstboot - VMware vCenter Server Firstboot Failed - "Failed to connect to SSO"
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vCenter Server Appliance 6.7 Migration Fails During Firstboot - VMware vCenter Server Firstboot Failed - "Failed to connect to SSO"

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Article ID: 338252

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

To learn more about firstboot issues see:
Understanding and Troubleshooting vCenter Server and vCenter Server Appliance 6.7 Firstboot Install/Deployment, Upgrade, or Migration Failures​.

To collect a log bundle or review log files for a vCenter Server Appliance install, upgrade, or migration issues reference :
Triaging a vCenter Server Appliance 6.0 installation, upgrade, or migration (6.0 U2m) failure.  

The relevant logs will be on the newly deployed appliance.  

In /var/log/firstboot/firstbootStatus.json file, you see that vpxd service failed to configure or start during firstboot :

"failedSteps": "vpxd_firstboot"


In /var/log/vmware/firstboot/vpxd_firstboot.py_####_stderr.log :

VirtualCenter firstboot failed


In /var/log/vmware/cloudvm/cloudvm.log :

Stdout: DNS reverse lookup on [IP_Address] has failed.
Unable to obtain hostname from DNS reverse lookup.
Please examine DNS/network configuration.

In /var/log/vmware/vpxd/vpxd-#.log :

Failed to connect to SSO

Environment

VMware vCenter Server Appliance 6.7.x

Cause

This issue occurs when deploying a vCenter Server Appliance 6.7 with an IP address that has no DNS record configured.  IP based deployments without DNS are not supported.

Resolution

Before deploying a vCenter Server Appliance 6.7 with a static IP address, verify that the IP address has a valid (internal) domain name system (DNS) registration.  

For more information about DNS requirements see: DNS Requirements for the vCenter Server Appliance and Platform Services Controller Appliance.